We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [package-repositories]

for questions about repositories of Emacs packages on well-known servers, such as MELPA, GNU ELPA, and Marmalade. Emacs uses library package.el to download and install updates to packages you choose.

Filter by
Sorted by
Tagged with
1
vote
0answers
16 views

Melpa package update question

Last year I created a package for Melpa. I have updated it in my Gitlab repo, but I don't know how to make Melpa aware of that. Thanks in advance for any tips on that.
1
vote
0answers
50 views

Unable to install a package

I am trying to add Magit to Emacs package list. I got as far as "Packages" menu and do not see how to add new, unlisted package. Is it even possible from Emacs ? I even tried to "i-install" ...
1
vote
0answers
69 views

Can not connect to a package archive?

I was trying to install beacon and got this error, package--check-signature-content: Failed to verify signature: "seq-2.20.tar.sig" Before installing, I ran package-refresh-content which gave an ...
1
vote
0answers
141 views

Getting error “Failed to download 'gnu' archive” on Emacs 26.3

I'm currently using Ubuntu 18.04, and trying out Emacs for the first time. However, whenever I run the command package-refresh-contents, I get the the follow error: Failed to download 'gnu' archive ...
0
votes
1answer
22 views

Melpa packages are not indexed before manually listing packages

I recently switched from sublime text 3 to emacs so I still don't quite understand everything. When I launch emacs and run package-install, I can not look up packages from Melpa to install, e.g., ...
3
votes
1answer
140 views

Trying to install auctex via package-install

I am trying to install auctex via M-x package-install RET auctex. Unfortunately after a brief splash of Contacting host: elpa.gnu.org:443, I end up with the message https://elpa.gnu.org/packages/...
0
votes
0answers
34 views

Debugging “Package lacks a file header”

I'm playing around with developing and publishing an Emacs package, very simple stuff, just trying things out before I commit to a bigger project. The problem that I'm having is that after I've made a ...
0
votes
1answer
19 views

Does it exists any library and or functionality that provides an API for indenting major modes?

I am currently maintaining a fork of a major mode and I usually get by through reusing snippets other people have written that provides indention for similar languages. However, this does lead to a ...
5
votes
1answer
2k views

Failed to download 'gnu' archive

I tried to install emacs and in an attempt to install MELPA, tried: (this is my init.el file) (package-initialize) (add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/packages/")) (add-to-...
4
votes
1answer
364 views

My init.el gets stuck on trying to install “spinner”, a sub-dependency of cider

I've installed emacs on a new machine (macos) brew cask install emacs. My init.el file gets stuck installing cider (clojure ide) because it requires "spinner". When I do: M-x package-refresh-contents, ...
3
votes
1answer
83 views

Is there a package manager for emacs that can use git repositories directly?

Is there a way to manage packages in emacs where I can point to a git repository directly? (like vim-plug for eg).
0
votes
0answers
46 views

How to use the same elpa directory to download packages for different Emacs starter kits

I am using different Emacs starter kits. The problem is that each starter kit, I use different directories (for example, for prelude I use´.emacsPrelude.d´, for SciMax I use ´.emacsSciMax.d´) . But ...
0
votes
0answers
19 views

Data structure for ELPA archive use of dotted pair [duplicate]

As a belated follow-up to this, can someone enlighten me why the data structure used in the ELPA archive-contents files is a dotted pair of a name (symbol) and a vector that contains a great many ...
0
votes
2answers
73 views

ELPA list is missing markdown-mode according to list-packages

I'm trying to install markdown-mode using instructions on https://jblevins.org/projects/markdown-mode/, according to which I put into my init.el file (require 'package) (add-to-list 'package-archives ...
0
votes
0answers
20 views

emacs-omnisharp unable to use unity project files

I'm using emacs-omnisharp to try to complete a project with Unity, but the omnisharp server doesn't seem to be able to open or use the project data. I know that the server works because I get ...
1
vote
0answers
93 views

MELPA no longer works: error in process sentinel: End of file during parsing

MELPA no longer updates after no changes of mine. With a minimal .emacs of (require 'package) (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t) (add-to-list 'package-...
1
vote
2answers
169 views

Package `emacs-25' is unavailable, trouble installing things from repository

I understand this has been asked before... I've done some research and found that emacs25 is not worth the transition. However I can't install many packages because they depend on it. Is there a way ...
3
votes
1answer
53 views

Is it normal for a package to request [sudo] in order to install a package? (this case pdf-tools) concerned about password integrity

I installed pdf-tools through MELPA, and then labels it as installed on a restart but kept viewing pdfs through doc-view. So using M-x pdf-tools-install it requested the sudo password in order to ...
2
votes
0answers
204 views

AUCTeX is obsolete on GNU ELPA?

I got this warning when installing AUCTeX from GNU ELPA. The package is installed, but I don't want to use obsolete packages for obvious reasons. I have check the official website of AUCTeX, and it ...
0
votes
2answers
216 views

Can't connect to package managers on multiple computers

I just did a clean install of emacs 26.1 on multiple computers running different OS (Ubuntu, Mint, Windows), and for some reason I cannot update my packages using M-x refresh-package-contents. I've ...
1
vote
0answers
134 views

Error on package-list-packages

I've started to get the following errors when running package-list-packages. Searching online hasn't come up with anything. If anyone can suggest a cause and/or a solution I'd be very grateful. ...
3
votes
1answer
696 views

gpg fails to find key to elpa archive

I'm getting this error while trying download a package from ELPA: Failed to verify signature archive-contents.sig: No public key for 474F05837FBDEF9B created at 2018-11-28T14:10:03-0800 using DSA ...
1
vote
1answer
467 views

Cannot install helm from MELPA

For some reason, I am unable to install helm. My configuration is: (require 'package) (add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/")) (package-...
0
votes
1answer
176 views

Automatically installing a built-in package from MELPA [duplicate]

This post is asking this question more clearly and concisely. My code contains the following function to install dependencies: (defun literef-install-packages() "Install any missing packages. The ...
0
votes
1answer
28 views

How to use the same melpa directoy for different emacs distrubitions

I have several emacs distributions (scimax, spacemacs, vanilla emacs, etc.) which all uses their own melpa directory. I want them all to use the same elpa (or melpa or gnu) directory to save some ...
3
votes
1answer
767 views

`org-bullets` - No longer needed

For a while, I've been getting the message Package menu: Operationfinished. 1 package no longer needed, type 'M-x package-autoremove' to remove them The package is org-bullets, very spread package ...
3
votes
1answer
116 views

use-package ensure not working: package downloaded but gives warning and skips config [duplicate]

I have the following code in my init.el file: (use-package org-plus-contrib :ensure t :config (progn (require 'ox-extra) (ox-extras-activate '(ignore-headlines)))) The :ensure t ...
1
vote
1answer
89 views

Confusing ELPA types

When listing ELPA packages (Mac running Emacs 26.1), I see two status types that beg questions: dependency and incompat. A dependency package does get automagically loaded but it also may be removed ...
0
votes
2answers
75 views

Where do folks go to search for elisp packages

I'm looking for a package that converts United States to us Netherlands to nl Where does one go to find Elisp packages? For Ruby there's rubygems.org, for example.
-1
votes
1answer
71 views

Updating cider to 20180624 hangs while compiling

When upgrading cider, emacs hangs while compiling cider-repl-handle-shortcut: I am running emacs 25.3~1.gite0284ab-kk1+16 on Ubuntu 16.04.4 LTS. The compile log buffer after C-g shows: Compiling ...
1
vote
1answer
269 views

M-x package-autoremove is blocked by system packages

Emacs doesn't want to autoremove packages from elpa because some of them are system packages. How can I launch autoremove ignoring system packages? Error enabling Flyspell mode: (stringp nil)106 ...
2
votes
0answers
52 views

Are there any lisp projects like jazz band?

I was curious is there anything like https://jazzband.co/ but for emacs lisp where you can submit packages so that they can be submitted / maintained by a group rather than an individual ?
2
votes
0answers
140 views

How to list all the packages installed from source

Is there a way to list all the packages originally installed via package-install-file? Looking at the results of package-list-packages, it doesn't differentiate between different installation methods....
1
vote
1answer
120 views

How to submit feedback to GNU ELPA?

I'm using cask and I usually reinstall all my packages every other day. Lately I have noticed a lot of Bad request responses from ELPA. I have to retry a few times before all the packages get fetched. ...
1
vote
1answer
166 views

Error with org-fstree: Symbol's function definition is void: reduce

I want to use the package org-fstree (MELPA Link). But in a file when I press C-c C-c at #+BEGIN_FSTREE: ~/ I get the following error: Symbol's function definition is void: reduce I am not sure ...
2
votes
2answers
421 views

list-packages crashes Emacs 25.3 (Mac) when MELPA is added to .emacs

M-x list-packages crashes Emacs after I added: (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/")) after (package-initialize). (package-initialize) alone works ...
14
votes
3answers
2k views

Dired+ missing from MELPA

I am trying to install dired+ from MELPA but it seems that it no longer is listed. I also checked here: https://melpa.org/ Is this normal?
0
votes
1answer
954 views

Emacs 27 MELPA connection failure on macOS

I have been trying to install packages ivy, counsel, and swiper on Emacs 27 prelude. Starting Emacs results in the following error: Warning (initialization): An error occurred while loading ‘/Users/...
1
vote
1answer
471 views

Loading ~/.emacs: cannot open load file, php-mode

GNU Emacs 24.5.1, installed MELPA, installed php-mode. The directory ~/.emacs.d/elpa/php-mode-20180105.541/ exists. I added the following lines to .emacs: (add-to-list 'load-path "~/.emacs.d/elpa") (...
2
votes
1answer
455 views

elpa certificate could not be verified

When I run package-list-packages, I'm getting an error: The TLS connection to elpa.gnu.org:443 is insecure for the following reason: certificate could not be verified I found a few other ...
4
votes
1answer
3k views

How do I work out what the problem is with the emacs package system?

I am trying to set up emacs (on cygwin / Win10) to handle JSON. I started with joshwnj/json-mode and was stoked to discover that emacs will now install its own dependencies from online repos. Fab ...
0
votes
0answers
38 views

Cannot access gnu.org from macOS

I am using a MacBookPro with macOS High Sierra 10.13.2 using Chrome as a browser. I cannot access elpa.gnu.org or www.gnu.org. As a result my emacs installation does not work anymore.
1
vote
0answers
163 views

How to override spacemacs package to use new ELPA version instead of pinned version

I'd like to use csv-mode 1.7 from ELPA, but spacemacs (develop branch) wants to use the pinned version spacemacs/.cache/stable-elpa/25.1.1/spacelpa-0.300/csv-mode-1.6.el (even if I delete that file ...
1
vote
1answer
114 views

SLIME 2.20 obsolete

Why the status of SLIME 2.20 (Superior Lisp Interaction Mode for Emacs) is taged as obsolete in emacs melpa considering it actually is the newest version of SLIME right now (2017/11/20).
0
votes
1answer
281 views

How do I install `mmm-mode` (through MELPA)?

mmm-mode is available on Melpa. Yet both `M-x` `list-packages` `C-s` `mmm-mode` and `M-x` `package-install` `mmm-mode` suggest that it's not. How do I install mmm-mode (through MELPA)?
1
vote
0answers
234 views

Cannot load markdown-mode

Problem I've recently switched to NixOS and I'm having a couple of problems with my init.el. One I think is NixOS related and so I won't elaborate here, but I can't think of any NixOS component to ...
0
votes
0answers
90 views

Accidentally deleted Ivy. Now what?

I went to M-x list-packages and accidentally deleted Ivy. How do I get it back in M-x list packages now?
3
votes
2answers
345 views

Keep spacemacs from retrieving package archives at startup

I'm trying to figure out a way to speed up my spacemacs start time. The main offender at the moment is the refreshing of package archives at start. I was hoping that setting dotspacemacs-check-for-...
0
votes
0answers
98 views

How to get path to library installed through elpa

I have Emacs installed on multiple machines, and every time I install yasnippet through elpa. As it's version changes, it is being installed into different directories. For example: #first machine ~/....
0
votes
1answer
210 views

How can I replace in my .emacs all these `require` with `package.el` and `MELPA`?

My .emacs still uses old-style (pre MELPA, pre package.el) initializations. Current (this works) I'll use web-mode as a concrete example. If I manually download web-mode.el and put it in ~/elisp, ...