Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

1
vote
1answer
151 views

What's the format of a `package-desc` for `package-install`?

The documentation of package-install says: "Install the package PKG. PKG can be a package-desc [...]", but then it doesn't explain what is the format of a package-desc.
1
vote
1answer
67 views

Installing a package via `package-install' in Lisp?

The documentation of package-install says: "Install the package PKG. PKG can be [...] a symbol naming one of the available packages in an archive in ‘package-archives’." To install the latest ...
0
votes
1answer
81 views

Json-Mode / Puppet-Mode unset common functions when installed with use-package

I'm facing a weird issue in my init.el. Installing packages such as json-mode or puppet-mode (from MELPA Stable) with use-package unsets common functions like forward-word or backward-kill-word. The ...
0
votes
1answer
72 views

Emacs - How “package management tool” got installed? [closed]

In emacs 24.5.1, M-x package-list-packages shows the list of packages. My understanding is, below elisp code should be part of my .emacs, (require 'package) (package-initialize) (add-to-list '...
2
votes
2answers
313 views

Use-package doesn't find autoload

I expect the package to be require'd as soon as mdi-insert is called but I get: Error (use-package): spaceline :config: Symbol’s function definition is void: mdi-insert ~/.emacs.d/init.el (let ((...
2
votes
2answers
653 views

Disable package without uninstalling

I installed package from M-x package-list-packages and want to disable this package without uninstalling. UPDATE With (setq package-load-list '((company nil))) I have in *Packages* buffer: company ...
2
votes
2answers
538 views

how do you disable all keybinding for a package?

Sometimes, packages override a whole host of existing keybindings from other packages. The keybindings get associated with infrequently used functions, so I don't even want to rebind them. This is a ...
2
votes
2answers
526 views

Defer loading packages with use-package and package manager

How can I defer loading a package when it is installed using package.el with use-package? Basically, I want the package I use to only be activated using use-package instead of package-initialize so ...
3
votes
1answer
59 views

What is the name of the package for quickly switching between windows by using some key and then a, b, c or d?

I remember using a package to quickly switch between windows, it was a key like C-something and then on each window a letter appeared for example if you have 4 windows then you have a, b, c and d. ...
0
votes
1answer
777 views

Uninstalling a package and all of its dependencies

Magit doesn't work on my system. I'd like to remove it and everything that came with it when I installed the package. How can I do this? What packages, beside Magit, were installed on my emacs when I ...
2
votes
2answers
76 views

Autoloads for “generated” functions?

I have a file that I want to turn into a (local) package containing (inter alia) the code: (defun tl-sort-regexp-fields (reverse record-regexp key-regexp beg end) "Extended sort function." (...
2
votes
2answers
2k views

Can't Install org Through Package Manager

I'm trying to upgrade org in my setup by following the instructions here but I don't see org listed as an option. The instructions say to report it as a discrepancy but I'm thinking it's more likely ...
0
votes
1answer
132 views

(require 'package) is newly very slow on Windows

In recent weeks, (require 'package) takes minutes. This only happens on Windows, not on macOS or GNU/Linux. What is going on? emacs-version is GNU Emacs 25.1.1 (x86_64-w64-mingw32) of 2016-11-15. ...
5
votes
3answers
228 views

Package manager: which files not to add to git?

I'm keeping my config-files in a git repository to use it on multiple different machines. I'm using the emacs package manager, but I don't want to add the packages to git, because which packages have ...
4
votes
1answer
89 views

Does package-install do byte-compilation?

When installing a package from the package menu, can/will package-install do automatic byte compilation of the installed package files? Or is this something the user must do manually himself ...
3
votes
1answer
57 views

how can I make a selectable list?

I'm working on a package and I want to present a list to the users that they can select from. The package allows editing of remote Dokuwiki pages from Emacs which can be found here: https://github....
0
votes
2answers
829 views

How to stop a minor mode from auto-loading in Spacemacs?

The smartparens minor mode is quite annoying to me, so I want to have it disabled on default. However, I don't want to uninstall it, in case I need it someday. Can I disable a minor mode without ...
0
votes
0answers
85 views

Cannot install auto-complete-auctex

I just installed auto-complete-auctex from melpa repository. At package documentation says to enable by putting in my .init file the following command (require 'auto-complete-auctex) However, when ...
1
vote
0answers
230 views

Adding package from non-standard ELPA Repository to Layer

So I have a package I would like to add from an ELPA repository different than MELPA. The repository is called "billpiel" and the link is http://billpiel.com/emacs-packages/. I would like to add the ...
2
votes
1answer
1k views

How to use clang-format package?

I installed clang-format package from the MELPA repository. I added it to the load-path in my init file. Whenever I try to use it it says: Searching for program: No such file or directory, clang-...
2
votes
1answer
66 views

Which archive did an installed package come from?

When I use list-packages it shows the archive for packages that are not installed, but not for ones that are. The same for package descriptions. Is there any way to find out which archive an installed ...
1
vote
0answers
52 views

Match paren problem in the GUI version of Emacs

I use the built in parentheses match (show-paren-mode t). But there seems to be somewhat of a glitch when it highlights the matching parentheses, because it moves the bottom lines further apart when ...
1
vote
1answer
113 views

Minimap package line highlight always on

I've installed a minimap package and when I disable and save 'show minimap line highlight' it keeps showing the line highlight anyway: Any obvious fixes, or is it just a bug in the package?
0
votes
1answer
232 views

Missing function in CEDET?

I get this error message when trying to configure CEDET: Symbol's function definition is void: ´cedet-gnu-global-version-check´ This is my elisp code: (require 'auto-complete) ; start auto-...
2
votes
1answer
454 views

Specifying local package loading order in spacemacs

I'm trying to create a layer where one package in the layer depends on the functionality of another package in the same layer. As spacemacs loads the packages alphabetically (I assume) this only works ...
2
votes
1answer
1k views

Setting up private layer with local files in spacemacs

I'm trying to get the unicode-math-input package up and running in spacemacs; the package depends on math-symbol-lists. Both packages are not featured in the official repositories. From what I know ...
1
vote
1answer
63 views

How to read proper formatted documentation for bookmark+ package?

I am trying to learn about the bookmark+ package. I installed the package from M-x list-packages and I am using Emacs 25.1. It looks like a great package, the only difficulty I have so far, is that ...
6
votes
1answer
2k views

How to automatically install all packages loaded by my .emacs file in the minimum of lines?

My ~/.emacs (which you can find on GitHub) file loads several different Emacs packages and I would like them to be automatically installed as soon as Emacs starts up, if they are not already installed....
2
votes
2answers
139 views

Coedit mode on Emacs

I often use the web service Kobra.io, in which we can edit a specific file with some people together at the same time. Is there such a package on Emacs? I'd like to edit a specific lisp code at the ...
20
votes
4answers
2k views

Easiest way to downgrade a package installed via MELPA

Sometimes, package updates from MELPA can break some part of emacs and when that happens I'd like to be able to revert back to using an older version of the package. Right now, I can do it in two ...
2
votes
1answer
203 views

Emacs (spacemacs) not keeping extensions

I installed emacs 25.1.1 on fedora and cloned the spacemacs environment. Then, I launch emacs and install some packages (e.g. magit). When I close and reopen emacs all my extensions must be ...
1
vote
1answer
115 views

What is disabling the dash package?

I'm trying to install the smartparens package, but I'm having trouble. When I go to M-x list-packages, mark smartparens for installation, and hit x (execute) y (yes), I get the error message: ...
3
votes
1answer
271 views

Emacs hangs after describe-variable on package-archive-contents

When I try run describe-variable on package-archive-contents C-h v package-archive-contents emacs hangs. It hangs at least 5 minutes, maybe forever (I did not wait any longer). Seems like Esc : (...
0
votes
2answers
263 views

Problems loading packages from repos in another emacs directory

I want to test a new configuration from emacs for that case I begin with this: emacs -q --load ".emacs.jesus.d/init.el" --debug-init it works and I load the emacs file, until I started to download ...
1
vote
2answers
104 views

Why does a package archive produce error “not an absolute file name”?

When starting an older Emacs (23.4, say) for testing, I get an error from package initialisation a certain package is not available for installation. list-packages also shows a failure but with no ...
0
votes
1answer
161 views

How to efficiently debug emacs package conflicts (strategies too)

I currently have an emacs package conflict occuring. It is a difficult one to pinpoint as it happens occasionally. I have started using M-x unload-feature to unload packages from memory, get out of ...
0
votes
1answer
323 views

How can I refresh the ELPA directory content without having to select and re-download the packages manually? (for slowed ver. 25.1 in Windows 10)

Hi fellow Emacs users, I'm experience very slower performance of 25.1 but a startup with -Q indicated the problem is probably caused by my old packages. (Similar scenario: https://www.reddit.com/r/...
2
votes
0answers
63 views

Distributing emacs packages with module functionality

How to distribute an emacs package via Elpa that includes OSX and Linux module written in C that needs to be compiled locally?
1
vote
1answer
22 views

Where the `l-pac` abrreviation for `list-packeages defined`?

Recent versions of emacs come with package.el built in and provide the abbreviation M-x l-pac. However, l-pac is not recognized by smex or helm-M-x. M-: (l-pac) also does not work and the help ...
3
votes
3answers
5k views

How to update Org to latest version using package repo's / git clone in Ubuntu

See the image below. . I want to update my org from Version: 2016071 to Version 20161003. It does not give me an option to upgrade when I use the package-list-packages command. An ...
2
votes
1answer
333 views

auto-complete Key binding doesn't work in one emacs mode

I have changed the keybindings for yasnippet and autocomplete so that I can use tab for indentation anywhere in a line without accidentally autocompleting or inserting a snippet. I have this in my ...
6
votes
1answer
1k views

Since Emacs 25.1, package-list-packages modifies and writes my .emacs

I've just installed Emacs 25.1. My .emacs works well on Emacs 24.5. But now that I'm on Emacs 25.1, when I do M-x package-list-packages, Emacs modifies and write .emacs in the background with the ...
1
vote
1answer
86 views

how to upgrade packages if init file calls package function?

[Note to folks with itchy 'close' fingers: this is not a duplicate of Noninteractively upgrade all packages, since those answers rely on code or package in one's init.el, which would suffer from the ...
1
vote
0answers
137 views

Error in using “helm-projectile-find-file”

This is my config in init.el: (require 'helm-projectile) (projectile-global-mode) (setq projectile-completion-system 'helm) (helm-projectile-on) (setq projectile-indexing-method 'alien) (setq ...
0
votes
1answer
2k views

emacs: reinstall package after installation error

I'm new to Emacs. I needed to install the elpy package for python (as described here), but as I forgot to install one python package with pip, the installation with M-x package-install RET elpy failed....
5
votes
2answers
1k views

How can I see which version of a package I'm using? [duplicate]

I'm curious to see which version of a package I'm using to see if it is out of date. I don't see a package- function that looks applicable.
0
votes
1answer
51 views

Using code from other packages in your own

I am currently making a package which is for my own use, but it will be publicly available on github. Some of the code is borrowed from another package. How do I properly accredit the copied code to ...
1
vote
1answer
97 views

Conflict in package installed with both package and el-get?

I list my packages: ;; List all packages installed with el-get-install (look for "installed" to find installed packages) (el-get-list-packages) ;; List packages installed with "package-install" (...
0
votes
1answer
2k views

File error: Cannot open load file

I have the following ~/.emacs: ;; Added by Package.el. This must come before configurations of ;; installed packages. Don't delete this line. If you don't want it, ;; just comment it out by adding ...
1
vote
1answer
1k views

How to use a github package instead of the built-in version?

I tried to install verilog-mode from github to replace the version built in to Emacs. I'm using spacemacs. I created a layer for verilog and added verilog-mode in packages.el: (verilog-mode :...