Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

1
vote
1answer
93 views

Conflict in package installed with both package and el-get?

I list my packages: ;; List all packages installed with el-get-install (look for "installed" to find installed packages) (el-get-list-packages) ;; List packages installed with "package-install" (...
0
votes
1answer
2k views

File error: Cannot open load file

I have the following ~/.emacs: ;; Added by Package.el. This must come before configurations of ;; installed packages. Don't delete this line. If you don't want it, ;; just comment it out by adding ...
1
vote
1answer
964 views

How to use a github package instead of the built-in version?

I tried to install verilog-mode from github to replace the version built in to Emacs. I'm using spacemacs. I created a layer for verilog and added verilog-mode in packages.el: (verilog-mode :...
2
votes
2answers
625 views

Get help for a package

Is there a way to get a quick help for a certain package? Something similar you get when you click package description in Paradox. I think it would be interesting a sort of doc package which get the ...
3
votes
1answer
443 views

How do I access a package's info manual?

I installed magit, and it appears to have come with documentation I can access in info-mode: > cd ~/emacs.d/elpa > ls -1 magit-2.8.0/{dir,*.info*} magit-2.8.0/dir magit-2.8.0/magit.info magit-2....
4
votes
2answers
334 views

Use `org-plus-contrib` to satisfy dependency of `org2blog`

Is there a way to tell package.el that the org-plus-contrib package I already have satisfies any dependency on org, so that installing packages that depend on org (such as the afore mentioned org2blog)...
0
votes
3answers
139 views

lazily activate an ELPA package?

I'd like a way to lazily activate certain ~/.emacs.d/elpa packages. I notice some of them have so many autoloads (which require other packages recursively from their *-autoloads.el), that you might as ...
1
vote
1answer
266 views

Is it possible to disable aggressive indent mode per file extension?

Would it be possible to disable aggressive indent package just for some file extensions?. I know it's possible to do it by major mode, but I use web-mode for js,html,php and others. And I just want to ...
1
vote
1answer
681 views

What does package-initialize do with package archives?

I'm reading through the definition of package-initialize to try and understand what goes on under the hood, and part of what it does is to read the package archive files. I see it comparing version ...
1
vote
1answer
140 views

use-package dependecy loop

I use use-package in my init.el and use :ensure to make sure packages are installed. However after every package update via package.el, it tells me some packages are no longer needed and can be ...
0
votes
1answer
280 views

Does installing packages using ELPA or MELPA need some additional steps for installing them manually?

I want to understand the different ways for installing a package, leading to readily using the package. I compared Emacs: How to Install Packages Using ELPA, MELPA and How to Install Emacs Package ...
1
vote
3answers
47 views

Using 'package as a filename in a declare-function statement?

I just saw this line near the top of the file use-package.el: (declare-function package-installed-p 'package) How can 'package be a useful 2nd argument, when the doc for declare-function says that ...
3
votes
2answers
2k views

“no match” error after `M-x package-install` on a package

I want to install https://github.com/syohex/emacs-helm-gtags, and here is the installation instruction: helm-gtags is available on MELPA and MELPA stable You can install helm-gtags with the ...
3
votes
2answers
490 views

How to install package without install dependencies through “package”?

I am using :ensure t of use-package to install "go-prjectile" package which depends on "go-rename". But I would like to use a local version of "go-rename" and its path is already added to load-path. ...
0
votes
1answer
102 views

emacs interface to ubuntu package management (apt, dpkg)

Is there an emacs library for managing packages on Ubuntu, ie an emacs based alternative to synaptic and aptitude? Presumably this would be an elisp wrapper around apt, dpkg and friends and look ...
3
votes
0answers
226 views

Spacemacs layer where package order matters

I'm trying to make a 'speedbar' layer that uses projectile-speedbar. The problem is projectile-speedbar won't compile unless sr-speedbar has already been compiled. Since spacemakes compiles the ...
0
votes
1answer
222 views

what backend package does spacemacs use for layout managment?

I saw a neat demo of the spacemacs layout feature: demo of the spacemacs layout feature, and another one. What package do they use to do that or another similar vanilla emacs package?
0
votes
1answer
427 views

Unable to install magit via package.el

I've been switching my .emacs.d to load packages via package.el instead of using gitsubmodules but I'm unable to install magit because emacs-24.4 isn't available. Getting the emacs version gives me: $...
1
vote
1answer
219 views

cadr wrong type argument listp

I have this code that used to work fine until today: (let* ((newest-pkg (cadr (assq 'org package-archive-contents))) (installed-pkg (cadr (or (assq 'org package-alist) ...
0
votes
1answer
49 views

How to require/provide a package name with the value of `user-login-name`, without hard coding it?

I am trying to load package depending on a user's login name For example: If a user's login name is "user_foo", I would like to (require 'user_foo). I don't want to hard code the user's login name. ...
3
votes
1answer
742 views

Installing AUCTeX, GNU Emacs 24.5.1

I'm very new to Emacs. I've installed AUCTeX version 11.89.4 using package manager (list-packages, select auctex, install it). It works, at least it shows compiled pdf result from test .tex file in ...
5
votes
1answer
2k views

What does (require 'package) mean for emacs and how does it differ from load-file?

I just began using emacs a few days ago and I read somewhere that (require 'package-name) is not needed when the said package is installed using package-install. But why, what does (require 'package-...
1
vote
1answer
48 views

What causes these extra spaces in front of the package menu header?

I want to get rid of these extra spaces that is in the left. I have tried the following after reading a bit on propertize: (setq-local header-line-format (propertize header-line-format '...
2
votes
1answer
147 views

Sources for Auto-Complete

I still feel a strong disturbance when it comes to auto-complete in emacs. From what I have read in the docs, you can easily extend auto-complete by any syntax you like. Looking through (M)ELPA there ...
12
votes
1answer
1k views

A non-free package in Emacs?

A while ago, I installed Emacs from the Ubuntu repositories, and have been using it occasionally. Recently, just for fun, I installed vrms, a tool designed to detect non-free software according to the ...
1
vote
0answers
52 views

Do Any Hooks for (Specific) Package Installation Exist?

I have a StumpWM configuration that loads a file contained in the SLIME package installed through Emacs (swank-loader.lisp). However, problems arise when my SLIME package is updated, because the ...
3
votes
2answers
135 views

Can I load a single package from a different archive?

For my main package loading, I want to use melpa-stable. There's at least one package (dash) that I know breaks my config if I use the melpa version. That's fine - I've no problem using melpa-stable ...
1
vote
1answer
139 views

(require 'flx-ido) fails, but “M-x flx-ido-mode” succeeds

I installed the flx-ido package from MELPA, and added the following two lines of code to my .emacs file. (require 'flx-ido) (flx-ido-mode 1) Emacs startup fails with the following error: File error:...
1
vote
0answers
49 views

describe-package commentary for non built-in packages

Currently, it seems like describe-package will only show the contents of the 'commentary' section for packages that are builtin. For example (describe-package 'python) show a detailed description of ...
1
vote
2answers
187 views

Info manuals from packages not showing up in info

I was just fooled by an old org info file that was hanging around in my info dir. I assumed that when I call (use-package wanderlust :ensure t) That the current info file would be installed ...
4
votes
1answer
238 views

Ensuring a minimum version with use-package

In my .emacs, I would like to ensure that the s package, version 1.10.0 or newer, is installed. If I use (use-package s :ensure t) it will not upgrade the installation on systems with older versions ...
1
vote
1answer
131 views

Stop “File not found in root path, do you want to change root?” message

When using Spacemacs and neotree, I often see this message pop up File not found in root path, do you want to change root? (y or n) If I say y, it moves neotree to the directory of whatever buffer I ...
8
votes
1answer
113 views

Why is Emacs asking me to save changed buffers, when I install a package?

Every time when I change something in a buffer, and then I decided to install a package from packages.el, Emacs is repeatingly asking me if I want to save the other buffers, because it's changed. I ...
7
votes
1answer
95 views

How should I bundle json with my elisp package?

I wish to distribute an elisp package that uses json.el (http://edward.oconnor.cx/2006/03/json.el). I need this to work for versions of emacs that do not come with json pre-installed (such as OSX, ...
5
votes
1answer
60 views

package-install is “checking” a lot of files

On running (package-install <some-pkg-name>), I am seeing a long list of messages of the form Checking /some/path/to/a/file. What are these checks that package-install does? How can I exclude ...
2
votes
0answers
349 views

Capture template `a': outline-show-all

After updating my Emacs packages, org capture templates fail with Capture template `a': outline-show-all, where a is the capture keystroke. Backtrace: Debugger entered--Lisp error: (error "Capture ...
2
votes
2answers
140 views

Manage packages completely inside emacs config file, not inside the Emacs directory?

i use currently melpa for managing my emacs packages, but I'm not satisfied with that. Melpa seems to manage the packages by dumping them into my emacs.d - which i don't want to store inside my ...
3
votes
3answers
349 views

Edit/fork packages installed via package-install

I would like to make a few changes to a package installed via package-install. What's the canonical way to do so? I understand that it would probably involve: Uninstalling the package via list-...
0
votes
2answers
148 views

autoload list of packages in Emacs 25.0.92

According to emacs.SE answer I am trying to make Emacs (version 25.0.92) autoload packages if they are not already installed on my computer. At my .emacs file now I have only: (package-initialize) (...
4
votes
2answers
544 views

Detect whether a package (AUCTeX) is installed from .emacs

In my .emacs, I distinguish between two scenarios: AUCTeX is not available. Then I load my customizations for the basic TeX mode — let's call that (my-tex-mode-customizations). AUCTeX is available. ...
2
votes
1answer
2k views

Emacs does not contain package “package”

I want to add C auto-completion at least so that I can use Emacs on a regular basis as my C editor. I am new to Emacs, and I had already it installed in my system, because it came with the OS (I think)...
5
votes
1answer
393 views

How do I set use-package-always-pin?

Emacs noob here, I want to use melpa-stable whenever possible for my packages. use-package has an option for this, use-package-always-pin. By default package.el prefers melpa over melpa-stable due ...
1
vote
0answers
52 views

Error installing “Package 'emacs-24.3' is unavailable” [duplicate]

I'm running emacs 24.4.1. Like the title says. When I run M-x package-install RET flycheck I get the message Package 'emacs-24.3' is unavailable Any ideas?
1
vote
1answer
209 views

Using cheatsheet.el and adding cheats to it

I have downloaded the package cheatsheel.el from Melpa for use in Emacs 25.5.1 in Ubuntu. However, I seem unable to add cheats to it because only the command (cheatsheet-show) is ...
0
votes
1answer
130 views

How to sort *packages* by Version

Is there a way to sort a list of packages in Package Menu (*Packages*) sorted by Version? If you are using melpa, you see that melpa versions each package with %Y%m%d.%d. I'd like to sort by the ...
0
votes
0answers
46 views

How to install movie.el (movie browser for Emacs)?

I found out there is movies browser for Emacs. But there is no instruction of how to get it works. https://github.com/larsmagne/movie.el
9
votes
1answer
381 views

Unload a whole package or library tree

Sometimes I want to call unload-feature to unload a library… and it a library depends on it… and another library depends on that library… How can I unload a library and all the libraries that depends ...
9
votes
2answers
311 views

How to blacklist a package?

I am using company-mode for completion purposes. But somehow, some package always draws in auto-complete as well, which collides with company-mode, since both offer a popup with completion candidates. ...
3
votes
1answer
168 views

How to get release note of updated package in Spacemacs

In spacemacs, you can update all the installed package. However, is there a way to get a release notes for each package which have been updated ?
2
votes
0answers
204 views

Org broke! How do I downgrade?

I started having some problems with org mode after upgrading my melpa packages. One of the problems is described in this question. I'd like to simply downgrade to my previous version of org-mode ...