Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

0
votes
2answers
5k views

How to install a color theme for Emacs 24?

Recently, I found a website providing many color themes for Emacs, so I decided to install one. However, I was confused by some instructions from web or other forums and I couldn't manage to install ...
0
votes
2answers
601 views

marmalade refused my handshake

I am behind a web proxy trying to connect to marmalade. Strangely, elpa works just fine, but marmalade fails. This is the traceback: Debugger entered--Lisp error: (error "Error during download ...
4
votes
1answer
202 views

`package` does not delete old version on update

Whenever package updates a package in Emacs 24.4, and it asks me if I want to delete the previous version, it fails to do so even when I answer y. It gives me the following message: Delete package `...
12
votes
3answers
965 views

Automatically update packages and delete old versions

I'm a bit compulsive about updating packages for all of my systems, so I find myself running list-packages -> U -> x -> y -> y pretty much daily to update my packages and delete old versions once the ...
4
votes
2answers
1k views

Dependencies of installed packages

Is there any way to see what dependencies has a package installed? In other words what other packages were installed with the first one?
12
votes
1answer
2k views

after-init-hook vs eval-after-load/with-eval-after-load

I've found the rather useful How Packages work in Emacs 24, however, I'd like a definitive answer from an experienced user or a core developer as to which of these is actually preferred in the typical ...
3
votes
1answer
3k views

How to install auto-complete via package system?

I'm trying to get work auto-complete. I've installed the package from MELPA successfully. However, it just does not work. When I enable auto-complete-mode the mode seems to be active (I see AC in the ...
1
vote
1answer
73 views

package status in *Help* doesn't refresh after install

I've noticed that since updating to Emacs 24.4, installing packages doesn't refresh their status after installation. If I install, it still appears available to install. How can I force it to refresh?
12
votes
2answers
8k views

How to navigate quickly to my installed packages?

When I'm in the package manager (M-x package-list-packages), I'd like to quickly navigate to my installed packages. There are literally thousands of packages marked as available, installed, or built-...
2
votes
2answers
285 views

How to debug inability to load library `auto-complete`

I am a new to Emacs , i downloaded auto-complete , moved it to ~/.emacs.d/plugins/ then modified the .emacs file to look like : (add-to-list 'load-path (file-name-as-directory (...
0
votes
1answer
57 views

How does autoload cookie work on non defun form

sometimes I see a "unkosher" use of autoload coookie, for example: ;;;###autoload (add-hook 'some-hook 'some-fun) How will the above work? Will it add a hook just by being installed (as autoloads ...
2
votes
5answers
346 views

Keep Emacs packages after reformatting

If I would like to keep my emacs settings and packages in another computer or after a format is there a way to avoid having to install all the packages from the beginning? I don't just mean saving ...
26
votes
2answers
4k views

Is it possible to use both MELPA and MELPA-stable at the same time?

I use melpa-stable as an additional package repository, but one of the packages I like to use (icicles) isn't available on melpa-stable. Is there any way to configure package.el to normally use melpa-...
5
votes
1answer
815 views

How can I get Cask or Pallet to automatically install packages on startup?

I manage packages in Emacs using Cask and Pallet. Yesterday I upgraded to Emacs 24.4; it went well enough, but all of a sudden all my packages were missing. Cask installs packages in separate ...
7
votes
2answers
2k views

“Symbol's function definition is void: cl-macroexpand-all” when trying to install php-mode

I'm trying to install php-mode, but I keep encountering this error when I run M-x php-mode: Symbol's function definition is void: cl-macroexpand-all The error persists whether I install php-mode via ...
12
votes
2answers
158 views

Proper approach to providing external programs along with packages?

I maintain a number of elisp packages (e.g. codesearch, emacs-ycmd, traad) that would benefit from being able to install the external programs that they use, saving time and effort for some users. For ...
1
vote
1answer
735 views

How do I fully uninstall/erradicate powerline?

I'm running GNU Emacs 24.4.1 (x86_64-apple-darwin13.4.0, NS apple-appkit-1265.21) of 2014-10-20 on builder10-9.porkrind.org, the one available form gnuemacsformacosx.com. After upgrading, my modeline ...
2
votes
1answer
1k views

void-function when loading ido-mode in Emacs24

I'm using Emacs 24.4.1 from Debian unstable and have added the lines from question "How do I switch buffers quickly?". However this results in an error message and I found no way to resolve it. I can ...
22
votes
6answers
5k views

Switching between window layouts

When I configure a custom layout and then just need to temporary look into one file fullscreen and once I want that layout back - I need manually to reflow it. I would like a plugin/elisp code to ...
3
votes
2answers
1k views

Why does (require 'use-package) fail from my init file, but succeed interactively? [duplicate]

With the following init file, emacs chokes on the first line: bash-4.3$ pwd /Users/sean/.emacs.d bash-4.3$ cat init.el (require 'use-package) (use-package package) bash-4.3$ emacs --version | head ...
11
votes
2answers
5k views

problem of loading a package at emacs startup [duplicate]

According to Emacs Eclim, I added the following to ~/.emacs.d/init.d for emacs-eclim: (require 'eclim) (global-eclim-mode) ; If you want to control eclimd from emacs, also add: (require 'eclimd) ...
7
votes
1answer
1k views

Concerns regarding uninstalling packages

In order to uninstall a package from Emacs I read that I must delete the specific folder from the elpa folder. As the .emacs file is being written by itself when I install a package does that mean ...
3
votes
2answers
2k views

Error while installing emacs-eclimd “Cannot open load file: auto-complete”

When I install emacs-eclimd, I get two errors Compiling file /home/tim/.emacs.d/elpa/emacs-eclim-20140809.207/ac-emacs-eclim-source.el at Thu Oct 23 09:47:40 2014 Entering directory `/home/tim/....
5
votes
2answers
7k views

package-install reports “no match”

From the Emacs Eclim github page: Install emacs-eclim. You have two options: Installation from the MELPA package archive. Just add the archive to package-archives if you haven't ...
1
vote
1answer
174 views

Emacs dot files & packages List for user switching from sublime and not founding a starter kit tailored for them [closed]

I'm trying to be able to answer to "sublime users" using a curated list of package, if not a working emacs config (like prelude or starter-kit does), but couldn't find any list or dotfiles for that on ...
27
votes
4answers
5k views

How to test REST API with Emacs?

I'm putting together an app, and want to be able to test the api end points. I figured Emacs would be a cool way to go - especially if JSON responses could be parsed and the return data used in ...
8
votes
1answer
187 views

How can I know which built-in emacs package needs to be 'require'd?

I was reading through the Changelog for emacs 24.4 (C-hn) and was trying to see what the File Notification feature is. I tried doing C-hv of a related variable auto-revert-use-notify but nothing ...
19
votes
3answers
5k views

How to use skewer-mode?

I am currently struggling to use skewer-mode in Emacs. I downloaded and installed skewer-mode via MELPA, so all the dependencies should be inplace. For testing purposes I even downloaded the boidsjs ...
3
votes
1answer
149 views

Automatically move installed packages to site-lisp to benefit all user accounts

I have scripts to setup virtual machine images, where emacs packages are installed for the root account. Currently, I manually copy them to the appropriate site-lisp directory, i.e. one of those ...
1
vote
1answer
892 views

Using ELPA in batch mode on Windows fails

I posted this question to help-gnu-emacs, but haven't had a reply there, so perhaps this is a different audience. I have an automated test suite that downloads a few packages from ELPA to simulate a ...
2
votes
3answers
836 views

install multiple packages from my .emacs file [duplicate]

I share my .emacs file between machines, which works great but I use a lot of packages and when emacs starts on a new machine with the .emacs it complains about the missing package. I can ignore it ...
13
votes
2answers
437 views

Why does emacs come packaged with games and amusements?

This question has confounded me ever since I was a freshman in college trying to subtly bludgeon my way through Dunnet in the lab without my professor noticing. Why in the world does emacs come with ...
4
votes
2answers
601 views

Problems installing packages via elpa that require cl-lib-1.0

I'm having problems installing package from (m)elpa which require cl-lib-1.0. My emacs version is 24.3, hence I have a builtin copy of cl-lib-1.0, however, the only version available via elpa is 0.5. ...
8
votes
2answers
915 views

How does emacs manage its packages?

I installed auctex from Ubuntu's software center, and then I installed a newer version of auctex from emacs. I then uninstalled the auctex installed by Ubuntu's software center. I found that it didn'...
54
votes
12answers
5k views

Synchronize packages between different machines

I use emacs in different places and I want to have a similar setup and packages installed everywhere. I guess I can use a version control repository for the setup files. Since I use Prelude, that ...
4
votes
2answers
92 views

What compilers are used during installation of a package?

When I download and install auctex, I read that The simplest way of installing AUCTeX is by using the Emacs package manager integrated in Emacs 24 and greater (ELPA). Simply do M-x package-list-...
118
votes
4answers
14k views

What are the practical differences between the various Emacs Package Repositories?

I notice that there are several different repositories that often contain the same software. Why would I want to prefer: GNU ELPA Marmalade MELPA over the others? Since any one repository does not ...
12
votes
2answers
4k views

How to proceed on package.el signature check failure

I just tried to install ascii-art-to-unicode from the gnu repository (http://elpa.gnu.org/) via list-packages. I get the following error: package--check-signature: Failed to verify signature ...
11
votes
2answers
315 views

What are some built-in packages with nice source code? [closed]

I'm trying to get familiar with Emacs Lisp, its syntax, data structures etc, so I was wondering what are some built-in packages whose source could help me better understand how to use the language and ...