Skip to main content

Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

108 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
8 votes
0 answers
1k views

error in process filter: could not create connection to marmalade-repo.org:433

When I run package-install in windows with Emacs 24.5.1 (i686-pc-mingw32) of 2015-04-11 on LEG570 I got error error in process filter: could not create connection to marmalade-repo.org:433 According ...
ironsand's user avatar
  • 423
6 votes
0 answers
1k views

libtool not found. Please install libtool

Linux Mint 21 Emacs 27.1 I want to install package "vterm". Here my init.el (use-package use-package-ensure-system-package :ensure t) (use-package vterm :ensure t :ensure-system-...
a_subscriber's user avatar
  • 4,174
6 votes
0 answers
461 views

How can I read -mdoc /-mandoc man pages using `M-x woman`?

I have been successfully using M-x woman to access the linux man pages. But when I tried to read the tmux manpage using woman, it did not work. But M-: (man "tmux") works. Using woman to ...
Kaushal Modi's user avatar
  • 25.7k
5 votes
0 answers
1k views

reload emacs package in current session after .el source recompilation

I have an emacs package installed from elpa in my ${HOME}/.emacs.d/elpa/ directory, and I am trying to fiddle with its .el source file. I would like to recompile after modification have those ...
grobber's user avatar
  • 151
4 votes
0 answers
59 views

Package to detect most common typing mistakes

I'm a decent touch-typist, capping out around 90 WPM, but I know I'd be better if I eliminated some of the more persistent typos that crop up semi-consistently. It occurred to me this morning that ...
NateEag's user avatar
  • 586
4 votes
0 answers
70 views

A workflow for managing compiled elisp packages with different versions of emacs

I am using different versions of emacs, on different computers. On some of those (work computers) I don't really have a choice to update, whereas for my personal computers, I like to run the latest ...
T. Verron's user avatar
  • 4,293
4 votes
0 answers
372 views

Info basics: where is package Info?

I just grabbed csv from elpa (melpa) and, of course, the install buffer had the blurb about csv. I take it that blurb is an Info file somewhere? Or is it just a section of the csv.el comments? In ...
147pm's user avatar
  • 2,979
3 votes
0 answers
49 views

How to declare a version of a local copy of existing package

Is it possible to identify the package version of a local copy/clone/fork of a Elpa supported existing package? Problem Scenario: A Elpa supported package (lets called it package-foo) hosted on some ...
PRouleau's user avatar
  • 831
3 votes
0 answers
193 views

What does it mean that something is an incompatible package?

I have some issues going on with my emacs and am getting an error where the stacktrace seems to indicate a potential issue with the parinfer package. I run describe-package on it and get parinfer is ...
George Mauer's user avatar
3 votes
0 answers
813 views

How to update Org-mode via Package Manager?

I have org-version 9.1.9 installed on Spacemacs and am attempting to install the latest org-version 9.2.6. Install instructions are on https://orgmode.org/worg/org-faq.html#installing-via-elpa and ...
wolfv's user avatar
  • 1,393
3 votes
1 answer
805 views

Debugging "Package lacks a file header"

I'm playing around with developing and publishing an Emacs package, very simple stuff, just trying things out before I commit to a bigger project. The problem that I'm having is that after I've made a ...
Nathan Campos's user avatar
3 votes
0 answers
652 views

AUCTeX is obsolete on GNU ELPA?

I got this warning when installing AUCTeX from GNU ELPA. The package is installed, but I don't want to use obsolete packages for obvious reasons. I have check the official website of AUCTeX, and it ...
nalzok's user avatar
  • 675
3 votes
0 answers
278 views

Spacemacs layer where package order matters

I'm trying to make a 'speedbar' layer that uses projectile-speedbar. The problem is projectile-speedbar won't compile unless sr-speedbar has already been compiled. Since spacemakes compiles the ...
Cameron Ball's user avatar
3 votes
1 answer
1k views

Installing AUCTeX, GNU Emacs 24.5.1

I'm very new to Emacs. I've installed AUCTeX version 11.89.4 using package manager (list-packages, select auctex, install it). It works, at least it shows compiled pdf result from test .tex file in ...
ars's user avatar
  • 183
2 votes
1 answer
45 views

Modify Emacs built-in .el files, but no effect after restarting Emacs

I'd like to debug some Emacs build-in .el source code. For example, start-process in subr.el. I added a log to this function, i.e. (message "Hello") (defun start-process (name buffer program ...
chansey's user avatar
  • 153
2 votes
0 answers
59 views

list-packages says certificate has expired. What I need to do?

I have not used Emacs for about six months. Today I tried to use M-x list-packages and there is an error, although I remember that there was no such error before: I use Emacs 27.1 on 32-bit Windows 7,...
john c. j.'s user avatar
2 votes
0 answers
244 views

package-load-descriptor: End of file during parsing

I've encountered this error on an Arch Linux system running Emacs-27.2. I sync my Emacs ~/.config/emacs/init.el which calls a host of other files located under ~/.config/emacs/settings/*-settings.el ...
slackline's user avatar
  • 345
2 votes
0 answers
442 views

Emacs and ASP.Net Razor Pages

I am trying to get .razor and .cshtml pages working in Emacs. My config is Doom Emacs with (csharp +lsp +dotnet). No issues with the C# code, that all works fine other than absurd refactoring ...
jgnovak-dev's user avatar
2 votes
0 answers
148 views

use-package & quelpa: resolve dependencies with elpa?

When modifying some packages I'm using (use-package :load-path "my-forked-project") but to make my config work in any machine I want get that package from say my github repo. I'm now trying ...
actondev's user avatar
2 votes
0 answers
95 views

How to make list-packages Help for dependency package show the dependee packages?

I use use-package to require the boxquote package into my GNU Emacs 26.3 running on Ubuntu 19.10, like this: (use-package boxquote :ensure t) In the list-packages buffer, I see the boxquote ...
bgoodr's user avatar
  • 351
2 votes
0 answers
57 views

Are there any lisp projects like jazz band?

I was curious is there anything like https://jazzband.co/ but for emacs lisp where you can submit packages so that they can be submitted / maintained by a group rather than an individual ?
Oly's user avatar
  • 593
2 votes
0 answers
167 views

How to list all the packages installed from source

Is there a way to list all the packages originally installed via package-install-file? Looking at the results of package-list-packages, it doesn't differentiate between different installation methods....
MLister's user avatar
  • 215
2 votes
0 answers
354 views

Package lacks a "Version" or "Package-Version" error, even if the "Version" info exists

After upgrading cask the error message changed. Wrong type argument: sequencep, pinyin-mode Original Question I want to use my elisp through cask. But it failed with error: Dependency pinyin-mode ...
ironsand's user avatar
  • 423
2 votes
0 answers
80 views

Error when I try to re-install package after deleting it

I used package-install to install the pamparam package. It worked. But in playing with it, I got it into a weird state and decided to uninstall and re-install. I uninstalled by deleting its dir in ....
vortek's user avatar
  • 253
2 votes
0 answers
227 views

Accidentally deleted Ivy. Now what?

I went to M-x list-packages and accidentally deleted Ivy. How do I get it back in M-x list packages now?
deshmukh's user avatar
  • 1,912
2 votes
0 answers
360 views

Lisp nesting exceeds max-lisp-eval-depth in python-mode 6.2.3, Emacs 25.2

I have this simple Python test program: #! /usr/bin/env python3 import numpy as np x = np.array([0, 1, 2, 3]) y = np.array([0, 1, 4, 9]) def gen_segments(x, y): for i in range(0, len(x)-1): ...
Håkon Hægland's user avatar
2 votes
0 answers
369 views

Adding package from non-standard ELPA Repository to Layer

So I have a package I would like to add from an ELPA repository different than MELPA. The repository is called "billpiel" and the link is http://billpiel.com/emacs-packages/. I would like to add the ...
DonyorM's user avatar
  • 121
2 votes
0 answers
105 views

Distributing emacs packages with module functionality

How to distribute an emacs package via Elpa that includes OSX and Linux module written in C that needs to be compiled locally?
licorna's user avatar
  • 207
2 votes
0 answers
381 views

Capture template `a': outline-show-all

After updating my Emacs packages, org capture templates fail with Capture template `a': outline-show-all, where a is the capture keystroke. Backtrace: Debugger entered--Lisp error: (error "Capture ...
Matthew Piziak's user avatar
2 votes
0 answers
483 views

Org broke! How do I downgrade?

I started having some problems with org mode after upgrading my melpa packages. One of the problems is described in this question. I'd like to simply downgrade to my previous version of org-mode ...
Brian Fitzpatrick's user avatar
2 votes
0 answers
479 views

How can I ensure that Org-Mode is Up-To-Date in init.el?

I want my init.el file to get the latest version of org from orgmode.org before loading my pretty-init.org. My init.el: (add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/...
Austin Wagner's user avatar
1 vote
0 answers
177 views

How do I set package-vc-selected-packages to use a specific commit?

Emacs 29.1 introduced new functions to install packages directly from source. Configuring it to download from the latest commit works fine, but I can't find how to download from a specific commit ...
Balto's user avatar
  • 11
1 vote
1 answer
48 views

Strange issue with dired-subtree

This is my simple config: (use-package dired-subtree :ensure t :bind (:map dired-mode-map ("<tab>" . dired-subtree-toggle))) The first time the ...
user129393192's user avatar
1 vote
1 answer
73 views

Cask without pallet

At some point, I found a web page that described using Cask and Pallet to configure emacs. I got that working, and life was good. I recently upgraded my version of Cask to 0.9.0, and now I find this ...
Troy Daniels's user avatar
1 vote
0 answers
142 views

How to have a multi-file emacs package?

Perhaps a beginner question, but I couldn't find a recommended way to split a package to multiple files. It's still a single package, just part of code is in a different file (so no (provide 'sub-...
Cigarette Smoking Man's user avatar
1 vote
0 answers
26 views

A new version of a package introduced unexpected behavior - how to discover the source of the issue?

My issue There is a small behavior in org-mode that I've grown accustomed to: if there are multiple headlines of the same level (e.g. 3 stars) and they are all folded (i.e. their contents are not ...
Alex's user avatar
  • 363
1 vote
0 answers
181 views

How to change this slime configuration on the init file from the classic imperative installation to a declarative approach via use-package?

When I first installed Slime, I used to install things via the classic M-x and package-install. Then, I inserted the following configuration: (slime-setup '(slime-fancy slime-asdf slime-indentation ...
Pedro Delfino's user avatar
1 vote
0 answers
354 views

How to change this Paredit configuration on the init file from the classic imperative installation to a declarative approach via use-package?

When I first installed Paredit, I used to install things via the classic M-x and package-install. Then, I inserted the following configuration: (autoload 'enable-paredit-mode "paredit" "...
Pedro Delfino's user avatar
1 vote
0 answers
283 views

Symbol's function definition is void: package-install-selected-packages

In order to install and remove packages automatically (which is especially useful when using Emacs for the first time on a new computer), I have the following lines in my ~/.emacs: ;; Specify required ...
HelloGoodbye's user avatar
1 vote
0 answers
317 views

How to set package-user-dir with Emacs 27 with package-quickstart and distinguish between graphical and terminal mode?

Goal: I would like to do the following with Emacs 27+: take advantage of the package-quickstart option to speed up startup, have 2 independent elpa directories: ~/.emacs.d/elpa when emacs runs in ...
PRouleau's user avatar
  • 831
1 vote
0 answers
74 views

Cannot load some modes via elpa

Some of my major modes, installed via ELPA, error during load as, for instance for markdown-mode, Debugger entered--Lisp error: (file-missing "Cannot open load file" "No such file or ...
Nordlöw's user avatar
  • 517
1 vote
0 answers
31 views

show which package repo was used to obtain a package

I'm trying to submit a bug report to emacs-evil, and they ask me from which repo evil was installed. I'm just using the version that came bundled with doom-emacs. How can I know which source was used ...
honestSalami's user avatar
1 vote
0 answers
56 views

Inconsistent behaviour with pretty outlines

SETUP: My .emacs.d/init.el reduced to the minimum (I have auctex and use-package installed) (require 'package) (add-to-list 'package-archives '("melpa" . "http://melpa.org/...
Lhooq's user avatar
  • 230
1 vote
0 answers
106 views

Manually installed pdf-tools breaks package handling because it is not recognized as a dependency

The situation is: I install pdf-tools manually and load it with the following snippet: (use-package pdf-tools :pin manual :load-path "my/load/path/to/the/git/repo/lisp" :config .......
Public Image Ltd.'s user avatar
1 vote
0 answers
3k views

.emacs showing error "Wrong type argument: listp, closed" during start up

I am getting an error Wrong type argument: listp, closed while starting my Emacs. I tried to debug each line and do a M-x eval-buffer during configuration. At at time, it was showing only End of line ...
Sreekumar R's user avatar
1 vote
1 answer
239 views

install dependencies for emacs package in a CI environment

I am testing an Emacs package on Travis CI with ert. A PR now requires the s package. This is how I currently make sure it's available in the test environment: script: - $EMACS --version - $EMACS ...
Tamas Papp's user avatar
1 vote
0 answers
344 views

Unable to install a package

I am trying to add Magit to Emacs package list. I got as far as "Packages" menu and do not see how to add new, unlisted package. Is it even possible from Emacs ? I even tried to "i-install" ...
Anne's user avatar
  • 11
1 vote
0 answers
163 views

Running logo program (ucblogo) in Emacs

I am trying to run logo programs (ucblogo version 5.5) on my emacs in Debian Linux (26.1). There is a currently a mode for it ( https://www.emacswiki.org/emacs/LogoMode ). I followed the instructions ...
ofenerci's user avatar
  • 337
1 vote
0 answers
52 views

Can't load spacemacs - it's trying to delete pspp-mode

I am a vim user who only uses emacs for my org-mode todo file, so I really don't know what I'm doing. After updating Ubuntu to 19.04 (and thereby updating emacs to 26.x), I'm getting an error when I ...
Jeremy's user avatar
  • 111
1 vote
0 answers
2k views

Proper use of use-package

I am using the following init file to download and load packages from melpa-stable in fresh Emacs installations: (require 'package) (add-to-list 'package-archives '("melpa-stable" . "https://stable....
antonio's user avatar
  • 1,822