Questions tagged [permissions]

The tag has no usage guidance.

12 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5 votes
1 answer
187 views

Get Administrator privileges on Windows via TRAMP?

I constantly use /sudo::/ URI schema on Linux to edit protected files. Is there something similar on Windows? Currently I start Emacs with Administrator privileges but that can lead to write ...
gavenkoa's user avatar
  • 3,412
4 votes
0 answers
2k views

Emacs won’t access Documents directory on MacOS Big Sur

I am running Emacs 26.3 on MacOS 11.2.1 “Big Sur”. When I try to open the directory ~/Documents, it fails with the message “Listing directory failed but ‘access-file’ worked.” Emacs.app is given ...
Mikelis Bickis's user avatar
2 votes
0 answers
302 views

pandoc: getCurrentDirectory:getWorkingDirectory: permission denied (Operation not permitted)

I'm trying to render the output of a markdown file using C-c C-c p. On doing so, a webpage opens on my browser displaying pandoc: getCurrentDirectory:getWorkingDirectory: permission denied (Operation ...
Saurabh's user avatar
  • 213
1 vote
0 answers
56 views

How to open file with it being editable but not writeable?

I teach, and I like to use real files as examples in class. I want to be able to edit the buffer to show student things, but I don't want to risk accidentally writing the changes on the file. What I ...
elPolloDiablo's user avatar
1 vote
0 answers
23 views

How to Set Visit File Keystroke to Ask Root Password If Needed in Dired Mode

Trying here to accelerate root file editing via dired mode. That way thought in somehow adjust visit file keystroke f, as default, to either ask for root password or to enter it as root automatically....
Renan41's user avatar
  • 65
1 vote
1 answer
1k views

Test file permissions in Windows

The file-writable-p docstring says: Return t if file FILENAME can be written or created by you. In Windows you cannot usually write on files when they are used by a different app. In these ...
antonio's user avatar
  • 1,802
0 votes
0 answers
36 views

Cannot save as root with tramp: “Unlocking file: Permission denied”

I'm using Emacs 27.1 in the terminal with tramp version 2.4.3.27.1. This is on a remote server over SSH. I can load files as root using tramp paths such as: /sudo:root@hostname:/etc/hosts or /sudo::/...
Ian Mackinnon's user avatar
0 votes
0 answers
24 views

Emacs unable to delete old package folders after package update from Google Drive

I am having an odd permissions issue with emacs 28.1 on Windows 11. My Home folder located in my Google Drive. The windows HOME environment variable is pointing to this folder and all works well. When ...
Steve's user avatar
  • 1
0 votes
1 answer
180 views

How to open serial-port with root privileges

When I try to open /dev/ttyUSB0 with serial-term, following permission error shows: Opening serial port: Permission denied, /dev/ttyUSB0 I know I can add my user to a group that has access to /dev/...
Garid's user avatar
  • 619
0 votes
0 answers
160 views

Emacs permission issues

I'm struggling trying to send email using mu4e. All is good using smtp but emacs does not want to go further as it stops saying it's impossible to create a directory (permission denied). Here is the ...
Guillaume's user avatar
  • 189
0 votes
2 answers
833 views

Emacs on Windows won't save

I'm a total beginner to Emacs. I followed the tutorial that came with it, but when I tried to use C-x C-s, the echo area shows the message Opening output file: Permission denied, c:/Program Files (x86)...
awe lotta's user avatar
  • 101
0 votes
1 answer
46 views

File within a root grandparent is detected by emacs as belonging to a directory that doesn't exists

I'm editing a file within a directory /parentdir/userdir/file with the following permissions: $ sudo namei -l $(pwd) drwxr-xr-x root root / drwx------ root root parentdir drwx--S--- ...
ABu's user avatar
  • 280