Questions tagged [smtpmail]

The tag has no usage guidance.

16 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
2k views

Sending smtp gmail via gnus

I am able to read gmail in gnus, but, after several hours of trying, am still not able to send gmail via gnus. I have searched extensively here and elsewhere, and have tried many configurations, ...
2
votes
0answers
481 views

Sending email through mu4e fails for other accounts

I'm using the latest stable emacs (26.1.91) compiled on my Debian 8 machine and I'm using ssmtp/sendmail to send emails. I'm trying to setup sending mail from multiple accounts within mu4e and it ...
2
votes
1answer
1k views

Can't get gnus to work with Gmail and GPG

I was once able to read and write my Gmail email in Gnus, but now I am unable to and can't figure out the problem. There seem to be several problems -- (a) with my gpg2 setup; (b) with my gnus nnimap ...
2
votes
0answers
595 views

Email sending failed

I send emails with C-x m and AFAIK everything is configured OK. However, recently I got this response when I wanted to send an email: smtpmail-send-it: Sending failed: 535 5.7.8 Error: ...
1
vote
1answer
36 views

gnutls-negotiate: GnuTLS error: #<process smtpmail<1>>, -15

Following Sending Mail Since no credentials are given in this configuration, Emacs will look them up in $(HOME)/.authinfo or $(HOME)/.authinfo.gpg (encrypted). The content of this file should ...
1
vote
0answers
127 views

SMPTmail suddenly isn't reading .authinfo properly. How can I fix it?

Some update must've made it so that SMTP mail isn't reading my password from ~/.authinfo any more. It reads everything else OK (hostname, port), but prompts me for my password the first time I try to ...
1
vote
0answers
644 views

SMTP auth credentials in emacs 24.x without an .authinfo file?

I know that the `smtpmail-auth-credentials' variable has been removed in emacs 24.x, and that we are now expected to use an .authinfo file. However, I have a specialized need for passing in SMTP ...
0
votes
0answers
18 views

Error message when posting to GMANE

When trying to post to GMANE, I get an error message: 441 You need a valid email address to post: Invalid response from SMTP server mail.inka.de: 550-Verification failed for auth@gmane-mx.org Couldn’...
0
votes
1answer
13 views

Sending mail from multiple domains with the same mail server

I use Emacs and mu4e to send mail. I have a mail server with Amazon WorkMail and I set up the information at ~/.authinfo.gpg. Two domains are in the same region and have the same SMTP server with ...
0
votes
1answer
9 views

mu4e with second account with a different stream type fails to send messages

I use Emacs and mu4e for email. I successfully set up Amazon WorkMail IMAP with Emacs and mu4e as a second account. My first account works with TLS: (setq ; ... smtpmail-smtp-server &...
0
votes
0answers
19 views

Unable to send email through my second account

I have set up email in emacs using mu4e for both my personal and university account (both use gmail). However I am unable to send email from my university account. Personal account works totally fine....
0
votes
1answer
97 views

Unable to authenticate sending mail using smtpmail-send-it to gmail, “Username and Password not Accepted”

I would like mu4e to use smtpmail-send-it to send emails from emacs. I would like smtpmail-send-it to authenticate using pass. I have 2factor auth on my gmail account, so I have to use an App Password....
0
votes
0answers
21 views

Passwordless `smtpmail-send-it` and queue

my current mu4e setup uses MSMTP utility to send out emails. Unfortunately if I want to use queues I have to use smtpmail.el which requires me either to (1) save my password in cleartext in .authinfo, ...
0
votes
0answers
203 views

mu4e with two contexts: no matching messages found, wrong type argument

I'm trying to set up mu4e with mbsync and two gmail accounts. The structure of my Maildir is as follows: ~/.mail |--> school_address |--> INBOX |--> Sent |--> Drafts |--> ...
0
votes
0answers
71 views

Can't change location of .authinfo

While using emacs e-mails, receiving works fine. Sending does not. If I place my .authfile in the home folder sending mails works fine. It does not ask for smtp server or user or password. If I move ...
0
votes
0answers
361 views

Sending email with gnutls stopped working

I've been using the following setup Gnus SMTP ;;; SMTP (defun email-settings () (interactive) (setq message-send-mail-function 'smtpmail-send-it starttls-gnutls-program "gnutls-cli" ...