Skip to main content

Questions tagged [sql-mode]

The tag has no usage guidance.

8 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers
146 views

How to abort a command executing in sqli-mode?

Whilst using a sqli buffer I accidentally ran a mahoosive query. What's the easiest way to abort it? I used sql-postgres to start the process.
cammil's user avatar
  • 509
3 votes
0 answers
112 views

Send custom commands via psql interface

When interacting with postgresql via Emacs sql-postgres, is it possible to write aliases or functions, to be able to type for example, databases instead of \l, when I want to list all databases?
Nsukami _'s user avatar
  • 6,531
2 votes
0 answers
47 views

Does `sql-mysql` work on MS Windows?

I remember that a few years ago when I tried there was an issue with the mysql client not supporting pipes on Windows or something like that, so it didn't work. I tried sql-mysql with Emacs 27 and it ...
Tom's user avatar
  • 1,270
2 votes
0 answers
28 views

SQL comint history saves spaces are \40

When accessing a database through an inferior process (M-x sql-msql) the history for the current session history (M-p/n) works Ok. But when restoring history entries from a previous session the string ...
PuercoPop's user avatar
  • 396
1 vote
0 answers
41 views

echo the sql-command after sql-send-region

Currently I can select a region and call sql-send-region, it can be executed well. But if the command needs a long time to run, I am not sure if the command was send or not until the command is ...
zhihuifan's user avatar
  • 165
1 vote
0 answers
72 views

Cannot set sql-buffer variable from within a SQL buffer

I'm trying to link a SQL buffer to SQLi buffer by calling sql-set-sqli-buffer but nothing happens when the function is called. I'm doing this because I want to start muliple SQLi buffers with each of ...
Joseph Tesfaye's user avatar
1 vote
0 answers
70 views

Why does sql-mode think -* starts a block comment?

While typing in a SQL mode buffer, I noticed that -* starts a block comment. Why? It happens whenever I type an asterisk/star character (ASCII 42) directly after a simple dash/hyphen/minus character (...
Michel de Ruiter's user avatar
1 vote
0 answers
286 views

sql-connect: (setting-constant nil)

I am using latest Helm from MELPA on Emacs GNU Emacs 25.0.50.1 (x86_64-unknown-linux-gnu, GTK+ Version 3.16.6) of 2015-09-11 When I issue sql-connect I see this: The only connection I have saved (in ...
Manuel Uberti's user avatar