Questions tagged [use-package]

is a macro package to isolate Emacs configuration lines in the init file. By isolating related lines, the configuration performs better and is easier to maintain.

Filter by
Sorted by
Tagged with
2
votes
1answer
67 views

How should I test that autoloads work properly with package.el?

I've added some autoloads to PACKAGE with the ;;;###autoload cookie and I've run M-x update-directory-autoloads which generated PACKAGE-autoloads.el. I have the following form in my init: (package-...
1
vote
1answer
153 views

How do I hide markup in Markdown mode with use-package?

I'd like to hide the markup in my Markdown buffers. I can do that manually using markdown-toggle-markup-hiding. However I'd like to configure this once and for all in my init.el so that I don't have ...
1
vote
1answer
1k views

How do I use use-package with diminish in my init.el?

It looks like use-package recently made a change and diminish is its own package. How do I install diminish which is its own package now? Here is what the top of my init.el looks like: ;; Save ...
2
votes
2answers
614 views

Rewrite a package config using use-package

I installed a package called persp-mode using package-install, and the package docs recommend the following configs in the user-init-file (the last two lines are mine, but they work as expected). (...
0
votes
0answers
257 views

How to use use-package's :bind to bind key-chords

(use-package whatever :bind (("C-a b" . aabb))) can be used to replace (global-set-key (kbd "C-a b" 'aabb)) Can use-package's :bind be used to replace (key-chord-define-global "ab" 'aabb) ?
0
votes
1answer
464 views

How do I bind keys using general.el alongside evil?

My goal is to bind SPC SPC to counsel-M-x. I've tried using this snippet from this post (use-package general :ensure t :config (general-evil-setup t) (general-define-key :states '(normal visual ...
2
votes
2answers
229 views

How can I set my Flycheck Perl include path?

I am using Flycheck using use-package like so: (use-package flycheck :ensure t :init (global-flycheck-mode)) I followed https://randstructure.wordpress.com/2015/06/21/using-emacs-flycheck-with-...
1
vote
1answer
2k views

How to install smart-mode-line powerline theme with use-package

I'm trying to move from el-get to use-package. I am having trouble with smart-mode-line-powerline-theme. Emacs complains at startup time with (error "Unable to find theme file for ‘smart-mode-line-...
0
votes
2answers
52 views

How can a use-package stanza be configured a setting depending on another package's existence?

I have this magit configuration which automatically sets the magit commit message buffer to evil INSERT mode, but it assumes that evil is installed and active which may not be the case. How can I ...
5
votes
0answers
2k views

Best practice for Emacs Helm setup after (use-package) verse [closed]

Just recently discovered use-package (a macro written by John Wiegley) that comes in handy if you want to avoid .emacs bankruptcy declaration and keep things tidy in your configuration dot file. ...
7
votes
1answer
1k views

Emacs setup for LaTeX after (use-package) verse

How to make this configuration file work with use-package with regard to AucTeX, RefTeX and LaTeX. I usually write latex rahter than pure tex documents. Current Working Emacs Configuration (load "...
4
votes
2answers
217 views

Dired+ hangs emacs in -no window mode

I have this in my init.el file: (use-package dired :init (progn ;; Details toggling is bound to "(" in `dired-mode' by default (setq diredp-hide-details-initially-flag nil)) :config ...
1
vote
3answers
355 views

use-package: load all defined packages

I use use-package to defer package loading. This is useful in emacs standalone mode. I additional run emacs in daemon mode (emacs --daemon), then this behavior is not desired. Is there a way to load ...
0
votes
2answers
206 views

use-package does not execute `:config`

When loading auto-complete via auto-complete-config with use-package, then :config is not executed and local keymap is not set. (See example below) Why that and how to solve this? Example: save ...
1
vote
1answer
591 views

use-package and auto-complete, howto?

How to use auto-complete with use-package and have auto-complete loaded later? Following config is working, but how to get rid of the defer 2? (use-package auto-complete-config :defer 2 :...
0
votes
1answer
198 views

Why is my use-package not installing packages properly? (Using org-mode init file and babel)

I'm new to emacs and I'm trying to setup my init file using a .org file with org-babel-load-file. I've read that it's a good idea to use package use-package to configure packages and to make sure they ...
1
vote
2answers
142 views

why is add-hook in use-package not erroring for function that does not exist

I have added a (add-hook 'js2-mode-hook 'my-js2-mode-setup) the following hook to a use-package init section: (use-package js2-mode :ensure t :interpreter (("node" . js2-mode)) :mode "\\.\\(js\\...
0
votes
1answer
86 views

Json-Mode / Puppet-Mode unset common functions when installed with use-package

I'm facing a weird issue in my init.el. Installing packages such as json-mode or puppet-mode (from MELPA Stable) with use-package unsets common functions like forward-word or backward-kill-word. The ...
4
votes
2answers
126 views

Dynamic package name with use-package

How can I call use-package with a variable as the package name? Something like: (setq my-pkg "magit") (use-package my-pkg :ensure t) It would be, for example, used in a mapc call. I tried ...
0
votes
1answer
270 views

I cannot type left open bracket into buffer

I have a very weird problem, I cannot type left open bracket character ([) into any buffer. Bracket itself is recognized when I: type anywhere outside emacs type in minibuffer use it as part of ...
2
votes
2answers
363 views

Use-package doesn't find autoload

I expect the package to be require'd as soon as mdi-insert is called but I get: Error (use-package): spaceline :config: Symbol’s function definition is void: mdi-insert ~/.emacs.d/init.el (let ((...
0
votes
0answers
68 views

use-package - load package depending on the OS username

I am not a Java guy at all, but I mess with it quite often for university reasons. I have used this awesome post by peter goldsborough to set up eclim. Which is nice! But this also requires a lot of ...
3
votes
0answers
508 views

error autoloading failed to define function when loading custom file

I recently decided rewrite my emacs configuration. I want to load my custom org configuration only in the case when I am opening a *.org file. Considering a minimalistic configuration of init.el (use-...
4
votes
1answer
7k views

Symbol's function definition is void: use-package

I am unable to get the darcula theme working. I have a tried moving (package-initialize) and (require 'package) but I am unable to get it working. Here is my init.el file. ;; Added by Package.el. ...
2
votes
2answers
583 views

Defer loading packages with use-package and package manager

How can I defer loading a package when it is installed using package.el with use-package? Basically, I want the package I use to only be activated using use-package instead of package-initialize so ...
0
votes
1answer
143 views

is byte-compile-dynamic compatible with use-package?

If I'm using use-package in a file that I plan to byte-compile, can I still leverage Emacs' byte-compile-dynamic setting to lazy-load compiled function definitions? From the Elisp manual: With ...
1
vote
2answers
205 views

use-package gnus ignores :bind

In my emacs config i wrote: (use-package gnus :bind (("<f12>" . gnus) :map gnus-group-mode-map ("q" . gnus-group-suspend) ("Q" . gnus-group-exit)) :...
0
votes
1answer
277 views

Where is `org-crypt` ? Need to install it with `use-package`

I am trying to use org-crypt but cannot find where exactly is this package hosted. I have: (require 'package) (add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/") t)...
20
votes
4answers
9k views

How to update packages installed with use-package

I'm using use-package to install and configure packages (most of these packages are in melpa). Is there a clean automated way of keeping all these packages up-to-date ? If not, what is the best work ...
5
votes
2answers
911 views

Does use-package keep packages automatically updated?

I'm using use-package in my init.el for all my package installations and configuration. I thought specifying :ensure t in use-package would make sure I always have the latest versions installed. But ...
1
vote
1answer
2k views

Package `exec-path-from-shell` isn't setting PATH variables from `.zshenv` on MacOS

I'm running a GUI Emacs compiled from the master git branch on MacOS El Capitan. I'm using the package exec-path-from-shell to set several environment variables I have configured in my ~/.zshenv file. ...
2
votes
1answer
731 views

How to customize org-agenda-* faces in .emacs file?

I am trying to customize org-agenda-* faces such as org-agenda-date, org-agenda-date-today, and org-agenda-date-weekend in my .emacs file. Normally, I install the use-package package to lazily load ...
2
votes
2answers
3k views

Install ESS with use-package

I would like to install the emacs speaks statistics package from melpa. I found the following snipped (use-package ess :init (require 'ess-site)) on this side https://emacs.stackexchange.com/a/...
1
vote
1answer
515 views

ESS language modes with use-package

I've recenly started to convert my init.el to using use-package, and have so far not found any problems with that -- except that I can't get ESS to work for all languages. I have installed the ...
2
votes
1answer
1k views

Setting up private layer with local files in spacemacs

I'm trying to get the unicode-math-input package up and running in spacemacs; the package depends on math-symbol-lists. Both packages are not featured in the official repositories. From what I know ...
2
votes
4answers
3k views

Setting up a theme using use-package

I'm doing a new setup so that I can have an init.el on my dropbox as a one stop shop for my configuration. So far so good but I'm stuck on the theme. When I setup the code using load-path it all ...
2
votes
1answer
324 views

Why do the latest versions of use-package and CIDER break each other?

Here is an example config to demonstrate the problem I am facing: (require 'package) (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/")) (package-initialize) (package-refresh-...
1
vote
1answer
418 views

Install package git-gutter or git-gutter-fringe conditionally

I’m trying to install git-gutter or git-gutter-fringe depending if I’m running in graphics mode or not. I have an if statement for that: (if (display-graphic-p) (use-package git-gutter-fringe ...
0
votes
1answer
62 views

Emacs init file with yasnippets and magit submodule update error

I have cloned yasnippets repo repo in ~/.emacs.d/yasnippet-snippets. I would like to synchronize it each time I start Emacs (btw, it would be nice to do it only if there is a connection available), my ...
1
vote
0answers
569 views

How to debug “company backend” initialization problems?

I am getting error messages initializing some company backend packages, but messages only appear in the *Messages* buffer, like: Company backend 'company-web' could not be initialized: Symbol's ...
4
votes
1answer
794 views

Activate global minor modes from use-package

I used global-company-mode from my .emacs like this: (add-hook 'after-init-hook 'global-company-mode) Now I’m trying to move to use-package, like this: (use-package company :config (global-...
0
votes
2answers
259 views

loading the `folding` mode with `use-package`

I am using the folding minor mode in Emacs which I get installed with the following use-package macro: (use-package folding :ensure t) The above works and ensures that folding is installed ...
6
votes
1answer
736 views

Why doesn't (use-package dired) work for me?

(use-package dired) complains: Debugger entered--Lisp error: (error "Package ‘dired-’ is unavailable") But I see others' emacs configurations do use (use-package dired), for example: https://github....
3
votes
1answer
594 views

How do I access a package's info manual?

I installed magit, and it appears to have come with documentation I can access in info-mode: > cd ~/emacs.d/elpa > ls -1 magit-2.8.0/{dir,*.info*} magit-2.8.0/dir magit-2.8.0/magit.info magit-2....
0
votes
1answer
95 views

Unbind `M-o` in diff-mode with use-package

I'm trying to unbind M-o in diff-mode with use-package. To do that I've written: (use-package diff :defer t :config (unbind-key "M-o" diff-mode-map)) Restarted Emacs 25, open a diff file, but ...
1
vote
1answer
152 views

use-package dependecy loop

I use use-package in my init.el and use :ensure to make sure packages are installed. However after every package update via package.el, it tells me some packages are no longer needed and can be ...
2
votes
2answers
595 views

How to install package without install dependencies through “package”?

I am using :ensure t of use-package to install "go-prjectile" package which depends on "go-rename". But I would like to use a local version of "go-rename" and its path is already added to load-path. ...
1
vote
0answers
55 views

Do Any Hooks for (Specific) Package Installation Exist?

I have a StumpWM configuration that loads a file contained in the SLIME package installed through Emacs (swank-loader.lisp). However, problems arise when my SLIME package is updated, because the ...
4
votes
1answer
278 views

Ensuring a minimum version with use-package

In my .emacs, I would like to ensure that the s package, version 1.10.0 or newer, is installed. If I use (use-package s :ensure t) it will not upgrade the installation on systems with older versions ...
1
vote
1answer
206 views

use-package and js2-mode: setting fill-column

I'm using use-package and I want my fill-column to be set to 100 for files edited with js2-mode. I tried to do so in the :config part, like: (use-package js2-mode :config (setq fill-column 100)) ...