Questions tagged [xemacs]

XEmacs is fork of GNU Emacs, providing much of the same functionality. XEmacs development is stagnant.

Filter by
Sorted by
Tagged with
32 votes
3 answers
812 views

What functionality is missing in GNU Emacs when compared to XEmacs?

In terms of functionality, what are the key points that presently distinguish XEmacs from GNU Emacs? To account for the different release schedules the most recent development version of each Emacs ...
paprika's user avatar
  • 1,962
3 votes
2 answers
851 views

Is XEmacs source code repository indeed lost?

Even though BitBucket service warned everyone quite in advance that it would stop hosting Mercurial repositories, it seems that in many months no-one bothered to convert XEmacs repository to Git. The ...
Bass's user avatar
  • 133
1 vote
1 answer
291 views

Install org module on XEmacs

I'm running Ubuntu 16.04. I installed XEmacs 21.4 (patch 22) I want to use org module BUT fail to install/configure it. In my case I don't use .emacs but rather I have ~/.xemacs/custom.el where I ...
susja's user avatar
  • 137
1 vote
1 answer
2k views

company-mode clang error

I am following this tutorial When having enabled company-node upon typing for instance std::vec I get error message in the mini buffer saying: clang failed with error 1: /usr/bin/clang -fsyntax-only ...
lo tolmencre's user avatar
0 votes
1 answer
110 views

converting xemacs lisp to run in emacs [closed]

I have used xemacs for years and have a lot of lisp code I have written. Now I want to switch to emacs and convert all the lisp code over to work in emacs. This is on an winXP machine. I'm sure I am ...
skm's user avatar
  • 3
0 votes
1 answer
298 views

Upgrade to 16.04 incomplete because of Xemacs

Yesterday, I ran an upgrade from 12.04.5 over 14.04.5 to 16.04.1. The first step (12.04.5 --> 14.04.5) worked quite well, no relevant problems. But the second step failed due to problems with some ...
BlackyDee's user avatar
0 votes
1 answer
75 views

is there a dired-like mode that behaves like XEmacs' dired

Having mostly switched to Emacs, I still sorely miss the dired mode of XEmacs. As far as I can tell, XEmacs' dired started from dired-x (not Emacs' dired) many years ago and then drifted away, so I ...
gboffi's user avatar
  • 604
0 votes
0 answers
20 views

Error in dired-find-file-place when saving

I've been an Emacs user for 30 years. This week I'm switching to a new machine with Ubuntu 21.10 installed. Now when I save a file, it always errors out with the error message: "Error in dired-...
rew's user avatar
  • 101
-1 votes
1 answer
90 views

why is save-buffer asking for a chmod?

All of sudden, XEmacs 21.4.22 starts asking whether it should chmod a+x $f everytime I try to save a buffer that is in Shell-script mode. Switching it to fundamental-mode stops that behaviour. ...
PypeBros's user avatar