Search type Search syntax
Tags [tag]
Exact "words here"
Author user:1234
user:me (yours)
Score score:3 (3+)
score:0 (none)
Answers answers:3 (3+)
answers:0 (none)
isaccepted:yes
hasaccepted:no
inquestion:1234
Views views:250
Sections title:apples
body:"apples oranges"
URL url:"*.example.com"
Favorites infavorites:mine
infavorites:1234
Status closed:yes
duplicate:no
migrated:no
wiki:no
Types is:question
is:answer
Exclude -[tag]
-apples
For more details on advanced search visit our help page
Results tagged with Search options user 115

for questions about initialization files `.emacs` or `init.el. DO NOT USE this tag if you assume answers require tweaking initialization files because many solutions do not involve directly manipulating initialization files.

14
votes
The culprit here is that you are doing (require 'org-mode) instead of (require 'org). But here's an alternative way to enable the minor modes that you need for org files (below is tested to work in …
answered May 10 '16 by Kaushal Modi
1
vote
As discussed in the comments, the solution is to ensure that (package-initialize) is in the emacs config. From the Package Installation section of the emacs Manual, In some circumstances, you m …
answered Jan 31 '16 by Kaushal Modi
5
votes
If you are open to installing a package, give use-package (also available on Melpa) a try, which comes with the bind-key.el library. With use-package installed, you can do something like below: (b …
answered Jul 9 '15 by Kaushal Modi
3
votes
If I would like to keep my emacs settings and packages in another computer or after a format is there a way to avoid having to install all the packages from the beginning? I don't just mean sa …
answered Nov 7 '14 by Kaushal Modi
2
votes
Here are few things to check when debugging why an installed package is not found by emacs: Install the package using the in-built package manager. Ensure that the parent folder of the package's ins …
answered Mar 2 '15 by Kaushal Modi
12
votes
The right way to do it would be (use-package markdown-mode :mode ("\\.markdown\\'" "\\.md\\'")) or (use-package markdown-mode :mode (("\\.markdown\\'" . markdown-mode) ("\\.md\\'" …
answered Oct 22 '15 by Kaushal Modi
0
votes
The add-hook forms need to go in the :config block instead of :init. As the package is not yet required at the time of evaluating :init, the HOOK to which the add-hook is adding a function is not …
answered Jun 12 '17 by Kaushal Modi
2
votes
Either you have a typo in your width setup or that variable existed in an older version of sr-speedbar. The variable to configure width in the current version is sr-speedbar-width (without the '-x'). …
answered Feb 11 '15 by Kaushal Modi
4
votes
The problem defun is already an elisp macro, which is similar to a function. So doing something like (defun defun () ..) is redefining the function called defun to do something else. Since defun is u …
answered Sep 27 '14 by Kaushal Modi
3
votes
I have this setup-packages.el in my emacs setup which is a hybrid of code from Prelude and Tomorokoshi's blog on Package Management. setup-packages.el does the following: Create a directory for elp …
answered Nov 7 '14 by Kaushal Modi
17
votes
The below would work. For the sake of clarity, I am using :ensure org-plus-contrib which deviates a bit from the example in your question. (use-package org :mode (("\\.org$" . org-mode)) :ensure …
answered Oct 29 '15 by Kaushal Modi
8
votes
github.com/altercation/solarized.git is the repository for the Solarized theme for vim. For emacs, the repo is https://github.com/bbatsov/solarized-emacs. The recommended approach to install the the …
answered Aug 27 '15 by Kaushal Modi