Skip to main content
Share Your Experience: Take the 2024 Developer Survey
4 votes

Nordic characters rendered incorrectly in non-file buffers

The fact that you could paste the characters in to your question and have them show up exactly the same as in your screenshot shows us exactly what is going on. Unicode has two diaeresis characters. ...
db48x's user avatar
  • 18.3k
2 votes

Nordic characters rendered incorrectly in non-file buffers

As @db48x says, the core problem is in the input method you use. Instead of creating precomposed Unicode characters, you keep producing the decomposed character pairs. This should not happen if your ...
Heikki's user avatar
  • 3,076
2 votes

Unicode input from keyboard (QMK) to Emacs

Here is an alternative solution that doesn't need special workarounds. This provides a function to trick emacs so that it accepts the unicode sequence: ;; enable standard linux unicode input (define-...
tristanC's user avatar
1 vote

Can't save file that contain German character ß in Emacs?

I think that this happened because I've updated my system while the Emacs was running. Restarting Emacs solved the issue.
jcubic's user avatar
  • 743
1 vote

Problem with UTF-8 characters in magit buffers

As comented by @db48x, the correct anwer for this is add to my early-init.el file this setting: (set-language-environment 'utf-8) This is also the suggestion in doom emacs configuration: https://...
anquegi's user avatar
  • 749
1 vote

Tramp resets file buffer encoding to UTF

Finally, it turns out to be a bug in Tramp, see bug#65022. It has been fixed, will be available with Emacs 29.2. The GNU ELPA package Tramp 2.1.6.2 will contain this fix as well.
Michael Albinus's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible