2

Looks like you are using a variable-width font, not a fixed-width font, for those menu items. Find out which Emacs face is used for Company menu items, and change its font to a fixed-width font by using M-x customize-face. I don't use Company, but a quick look at company-template.el, which is where its faces are defined, suggests that maybe the face you ...


2

Is it expected that dir-local variables are applied only after major-mode hooks are run? Yes. The local variables are normally processed in run-mode-hooks, after running the mode hooks and before running after-change-major-mode-hook. You could use the latter to deal with your problem. Alternatively you can use hack-local-variables-hook which runs after ...


2

Completely untested: (add-hook 'c++-mode-hook (lambda () (when (file-remote-p default-directory) (company-mode -1))))


1

The following snippet works for me. I use use-package, so it is slightly different, but I hope it is easy enough to edit. You can evaluate this with emacs -q and then calling M-x eval-buffer on the snippet. (require 'package) (setq package-user-dir (expand-file-name "~/.emacs.d/elpa/") package-enable-at-startup nil) (add-to-list 'package-...


1

Edit: not being a python programmer I hadn't actually looked up Jedi. Jedi is an emacs extension. Why not just use that? It IS integrated with company mode. See here: Python Programming in Emacs (defun company-jedi-setup () (add-to-list 'company-backends 'company-jedi)) (add-hook 'python-mode-hook 'company-jedi-setup) and (setq jedi:setup-keys t) (...


1

Your setting looks valid, but since it is not doing, what you expect, you probably changed the wrong keymap. exchange your (define-key... line by: (define-key company-active-map (kbd "C-h") nil) if you have set up your emacs to normaly delete chars with C-h or (define-key company-active-map (kbd "C-h") #'backward-delete-char) otherwise. Note: you can ...


1

In order to know that a buffer represents a remote connection, you can use file-remote-p. You can read about this function Here For example, in a shell buffer, (file-remote-p default-directory) will allow you to differentiate between a local shell and a remote shell. In order to toggle company-mode, you can call the company-mode function with a parameter ...


1

There's been a recent development that might solve the issue for people in the future. It turns out that the contextual help at the bottom in the minibuffer that appears when you're getting autocomplete is massively inefficient. This seems to be an isolated issue when company-mode is on. The current "fix" is a flag someone put into a very recent ...


1

I ran into a similar problem with a similar setup; I also got the warning: company-lsp is no longer supported, using company-capf Just updating all my packages did not solve the problem, however removing: (push 'company-lsp company-backends) from my configuration fixed the error and idle completion works again.


1

Yes, it is possible. I use the following. (setq company-ispell-available t) (setq company-ispell-dictionary "/path/to/your/wordlist/file") (add-to-list 'company-backends 'company-ispell) The other answers are valid alternatives, here we are passing a custom-populated file to company to help auto-complete.


1

I had the same problem, this seemed to do the trick ((c-mode . ((company-clang-arguments . (list ("-I/your/absolute/paths/here/")))))) on .dir-locals.el


Only top voted, non community-wiki answers of a minimum length are eligible