Hot answers tagged

11

This particular error happens if Emacs failed looking up the latest version of a package, like if there's no package-archives file containing that information. Before installing packages, make sure to run M-x package-refresh-contents so that there is one. Alternatively, use M-x package-list-packages for installing packages, that ensures that the package-...


6

I am adding this answer as suggested by @Drew. I appreciate the answer from @wasamasa which allowed me to get this working in my .emacs file. Here is how I modified my .emacs file. (package-initialize) (package-refresh-contents) (package-install 'use-package)


6

This question is also being answered here (since you already found my github bug report): https://debbugs.gnu.org/cgi/bugreport.cgi?bug=23529 For the moment, and likely it will be this way until the emacs build system changes, the only valid solutions are: Don't build with a Dockerfile and build in a running container that has a seccomp profile that ...


4

If I understand your question correctly, the simplest solution that I have found is to set the variable directory-abbrev-alist to map directories in the compilation buffer to the host system. For example I run my phpunit tests in a docker container as a compile command. When there are errors or failures the filepaths in the compilation buffer show up as /...


2

Thanks to the help of @ChakravarthyRaghunandan and @Kaligule and rereading the Melpa getting started I have been able to use use-package to install magit in a docker container in emacs-nox. The dockerfile starts with FROM debian:stable. At Melpa - Getting Started, it says: There are some problems using the https location with Emacs on Windows. There is ...


1

This was somehow ido-mode's fault. Disabling ido-mode in my emacs config fixed it. No idea why.


1

Your value of PS1 contains ANSI escape codes that can only be processed correctly by a terminal emulator (like the built-in term.el or vterm), not by M-x shell or M-x eshell. Set it to something simpler like \u@\h:\w\$, this could be done with the -e switch for the docker-container-exec command.


1

I solved this using an awesome docker-tramp.el. It offers TRAMP method docker to access running containers, so I can do: C-x C-f /docker:container:/path/to/file And then use sql-mode as usual


1

I use next function to run rails console on remote host. It seems that run-ruby doesn't care how REPL is started, so I pass it an ssh command. Most important part is the command itself: -t for pseudo-terminal mode, without it repl won't work; bash --login to get usual shell (for rbenv, rvm or other stuff that initialised on shell startup). If you use zsh, ...


1

You can disable dumping with env CANNOT_DUMP=yes ./configure. Does this not work on Docker?


Only top voted, non community-wiki answers of a minimum length are eligible