We’re rewarding the question askers & reputations are being recalculated! Read more.

New answers tagged

0

I found one solution to this problem on this reddit comment (under the EDIT 2 part). I added this line to my init.el and emacsclientw.exe loads the proper font: (add-to-list 'after-make-frame-functions (lambda (frame)(when (window-system frame)(originalPosition)))) But this solution has created another problem - it loads different frame sizes than that ...


1

You can do this with set-fontset-font, which allows overriding the builtin selection mechanisms for fonts for specific characters, charsets or scripts. So in your case, something like: (set-fontset-font "fontset-default" 'hebrew (font-spec :family "Dejavu Sans Mono" :size 20)) See Modifying-Fontsets for more info.


1

M-x customize-face default, then set the height attribute to the value you want. There are several other approaches. Here's one involving default-frame-alist: Use M-x customize-option default-frame-alist, providing a full font name for the value of frame-parameter font. For example: this value uses a font height of 16 pixels: "-*-Lucida Console-normal-r-...


1

You can define a new function that minimize the font size and bound it to an unused keybinding. (defun my-text-scale-minimize () (interactive) (text-scale-increase (text-scale-min-amount))) (global-set-key (kbd "C-c -") #'my-text-scale-minimize) If the font size is too small replace (text-scale-min-amount) with a negative integer. To restore the ...


0

This is Drew answer in details. Configuring emacs menu is tricky but solvable. The problem is that emacs could be built with different visual libraries (like GTK, motif, lucid...) that affect on the menu apperanse different ways not related to emacs. So what to do: Understand which visual library your emacs is build with. Menu Help > About emacs. In my ...


Top 50 recent answers are included