3

If you really just want a list (and not a tree like format-mode-line) that can be evaluated takes element-wise to strings and then concatenated mapconcat and eval are your friends: (let ((my-list '("Hello, I am " (number-to-string (user-uid)) " and it is " (format-time-string " %T, %F")))) (mapconcat #'eval my-list ""...


3

What TAB does now is indent-for-tab-command. What you want is tab-to-tab-stop. The latter is available at M-i, so one option is to learn to use that. To always bind TAB to run that command in Text mode, you can put (add-hook 'text-mode-hook (lambda () (define-key text-mode-map "\t" 'tab-to-tab-stop))) in your init file.


3

view auto-mode-alist using: M-x describe-variable RET auto-mode-alist Then edit the list by adding to your init file: (add-to-list 'auto-mode-alist '("\\.pyt\\'" . python-mode)) Per the docs here


2

As @rpluim mentions in a comment, setting org-export-with-sub-superscripts to nil would disable the special handling of ^ and _ for subscripts and superscripts. There is one more variable that is relevant (when org-export-with-sub-superscripts is t) and that is org-use-sub-superscripts which can be set to t or nil - or it can be set to the value {}. I find ...


2

This is a literate org-mode answer. Copy the whole answer into an Emacs buffer, run M-x org-mode and experiment with the code blocks. You can use a [[info:org#Results of Evaluation][:post]] processing step to limit the number of lines (or list items). The following emacs-lisp snippet takes either a string or a sequence. If DATA is a string, it will split ...


1

Got it: the faces org-column and org-column-title had no font and size set. After setting it to a Monospace font, the columns align. But I'm sure, it worked before without specifying. Don't know what changed.


1

Entries in LaTeX-indent-environment-list control the filling behavior in environments. If you want the standard filling AUCTeX applies to environments, remove entries for your appendices from it and M-q should work again. The appendices environment is provided by LaTeX package appendix.sty. In order to get auto-completion for it when you hit C-c C-e, you ...


1

Just to make it clear, this is not a problem with exporting, but of showing entry text in the agenda. Turns out there is a variable to exclude text that matches a list of regular expressions. You can exclude anything that looks like an active timestamp (there is also the variable org-element--timestamp-regexp but that did not work in my tests): (setq org-...


1

You can do this with smartparens: (require 'smartparens) (require 'smartparens-config) (define-key smartparens-mode-map (kbd "C-<backspace>") 'sp-unwrap-sexp) (define-key smartparens-mode-map (kbd "M-<backspace>") 'sp-backward-unwrap-sexp) For example: This is *bold* and th|at is *bolder*. Pressing M-<backspace> ...


1

You can remove the leading stars. This will prevent the exporter from formatting your headlines as headlines if that makes sense. In your case the easiest way of doing this is with the following advice: (advice-add 'export-translation :after (lambda (backend) (org-map-entries (lambda () (when (...


1

There is a slightly more detailed description of what you are doing in your other question - I provide the link here just to clarify to potential answerers what you are trying to do. Both of your questions basically ask: how can I force Org mode to do what I want? In the first one, you want to export part of the document: Org mode has facilities to export ...


1

C-c . just sets the formatting style to use when indenting the code, it doesn't actually change the indentation of anything the buffer. You can change the indentation of a region with the indent-region command, bound by default to C-M-\. c-mode also has the c-indent-exp command that indents an expression; this is handy for multi-line expressions near the ...


Only top voted, non community-wiki answers of a minimum length are eligible