Hot answers tagged

2

As an alternative, you can use the ox-pandoc package. Pandoc itself has a command line option called --self-contained which will embed images in html. To you use this for just the pandoc HTML5 exporter, by putting this in your .emacs: (setq org-pandoc-options-for-html5 '((standalone . t) (self-contained . t))) Also, you could have it for html4 instead/as ...


2

You need to provide a path: [[./KLOCKA6.JPG]], otherwise the link is not recognized as a file link. Alternatively, you can make sure that it is recognized as a file link if you write it explicitly as [[file:KLOCKA6.JPG]]. See External links.


2

I've found a solution using SVG.


2

Yes it is possible (at least with Emacs 27 running locally) with M-x markdown-toggle-inline-images or C-c C-x TAB


1

I don't think that there is anything ready-made, but it does not take too much work to create something like that. The main question is what interface you find convenient. org-toggle-inline-images (bound to C-c C-x C-v) calls the function org-display-inline-images underneath the covers (that is mentioned in the doc string BTW - do C-h f org-toggle-inline-...


1

The issue is that openwith is set to open any .png file with the external program xnview. Remove "png" from the fourth openwith-make-extension-regexp list and reload. Now emacs will handle the .pngfile natively if it can.


1

Just load standard library dired-x.el, customize option dired-guess-shell-alist-user, and use ! in Dired, to open whatever program you want, by default on the marked files or a single file, for whatever image-file extensions you want. C-x v dired-guess-shell-alist-user: dired-guess-shell-alist-user is a variable defined in dired-x.el. Its value is nil ...


1

There is a variable image-auto-resize which you can customize to fit-width: image-auto-resize is a variable defined in ‘image-mode.el’. Its value is ‘fit-width’ Original value was t You can customize this variable. This variable was introduced, or its default value was changed, in version 27.1 of Emacs. Probably introduced at or before Emacs version ...


1

This is a known issue with Emacs, documented as issue #1 in bug report 40845. I've copied that portion of the report here for convenience Manually scaling an image, as is done for the second image, doesn't re-render the svg: is scales the bitmap-rendered version of it, causing blurriness. There's a patch in that chain, although it doesn't seem to have been ...


1

Reading comments, the first thing you should do is read the documentation of org-preview-latex-process-alist. How? Do C-h v org-preview-latex-process-alist RET. This will familiarise you with how Emacs actually makes those svg images. Then once you know what you are doing, this code will make more sense. The default value of preview-latex-process-alist is ...


1

I have a solution that does 2 things: Attempt to open any XML file in nXML mode, and this obviously needs to include SVG files. If such a file is an SVG file, then define C-c C-c to image-mode. For the first item, I use magic-mode-alist to select nxml-mode on some sequences at the beginning of the buffer: <?xml, some DOCTYPE line with XHTML, and <svg ...


Only top voted, non community-wiki answers of a minimum length are eligible