New answers tagged

0

I found a .el file for M+ 1mn in Gist. https://gist.github.com/makotoy/3929218 And changed my init.el like ;;(when (member "M+ 1mn" (font-family-list)) ;; (add-to-list 'default-frame-alist '(font . "M+ 1mn-12"))) (create-fontset-from-ascii-font "M+ 1mn:pixelsize=16:weight=normal:slant=normal:spacing=m" nil "mplus1mn") (set-fontset-font "fontset-mplus1mn" ...


0

It seems that the bug occurs because I set straight-use-package-by-default using the customize-interface. When I set the variable outside of custom-set-variables everything works fine.


0

You need to add the straight keyword in the use-package macro call e.g. add :straight t From straight.el documentation https://github.com/raxod502/straight.el#integration-with-use-package To use use-package, first install it with straight.el: (straight-use-package 'use-package) Now use-package will use straight.el to automatically install missing ...


-1

In general you need to initialize the package system if you're going to use packages at init time. i.e. Do this first: (setq package-enable-at-startup nil) (package-initialize) (That said, I'd be slightly surprised if use-package didn't do that itself, so maybe this isn't the issue; but it's certainly worth testing it.)


0

This error basically means the function is not defined. In order for it to be defined you have to ensure the file defining it is loaded. This is classicaly done by something like (require 'rtags). Indeed, the minimal init.el configuration mentionned in the link you provided does include it: This minimal init.el configuration should be enough to get ...


0

So I added the following lines to the config (add-to-list 'load-path ".emacs.d/elpa/rtags-20190820.502/") (require 'rtags) and now it is working fine.


0

It turns out that my setup after requiring the files was ok, but the file itself was wrongly formatted. So a working example is then the following: init.el: (require 'epa-file) (epa-file-enable) (setq custom-file (expand-file-name "secret.el" user-emacs-directory)) (load custom-file) and the following file: ;;;; -*- epa-file-encrypt-to: ("kramer@example....


1

Elpa seems to be having issues again. (Reddit discussion.) Maybe try adding (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3") to your config as mentioned here.


Top 50 recent answers are included