1

Try binding keys also in isearch-mode-map. These keys are among those bound there by default, for example: C-r isearch-repeat-backward C-s isearch-repeat-forward C-M-r isearch-repeat-backward C-M-s isearch-repeat-forward M-r isearch-toggle-regexp M-s r isearch-toggle-regexp For example: (define-key isearch-mode-map (kbd "C-s") '...


1

The following setting makes the left alt/option key behave like a system default key (so that one may use special symbols, foreign language characters, and so forth), and the right alt/opion key behaves as the Meta key: (setq ns-alternate-modifier 'none ns-right-alternate-modifier 'meta)


1

Just found this issue, looking around the internet I came across this page, and the solution is at the bottom, basically you have to set the keyboard mapping with the following command on the Debian terminal: setxkbmap us -variant intl I use US-INTL, so from what I am reading on your question, this is your case too. Finally you might want to add it to your ....


1

Odd solution. In Manjaro I'd inadvertently set the Japanese keyboard layout. X emacs was respecting that setting, whereas the console version, and all other X apps were perhaps following locale.


1

In non-windows mode, changes to ns-* variables (such as ns-alternate-modifier and ns-command-modifier) are ignored. In particular, if the -nw option is passed as argument to emacs, the logic that propagates changes to ns-* variables (implemented in src/nsterm.c) is not evaluated. See the call to init_display in the src/emacs.c in the Emacs 27.1 source code. ...


Only top voted, non community-wiki answers of a minimum length are eligible