New answers tagged

0

You could turn your SETUPFILE into a LaTeX class .sty file, and install that .sty file where LaTeX will find it. Then you can add your new package to the list of packages org automatically includes everytime you export to pdf by customizing the variable org-latex-packages-alist.


0

AucTeX automatically provides a list of environments for you to insert. This includes a set of 'default' environments, based on a hard-coded set of environments commonly associated with the documentclass of your file. Additionally, AucTeX parses the header of your file, and if it detects any packages that provide additional environments, these are added to ...


1

(Posting the 'update' to my question here as an answer.) The way to implement abo-abo's suggestion should instead be this: (defun electric-space () ; Trying to get Emacs to do semantic linefeeds (interactive) (if (looking-back (sentence-end)) (insert " %\n") (self-insert-command 1)) ) (defvar electric-space-on-p nil) (...


1

Something like this seems to work as you want: * list #+ATTR_LATEX: :options \setlength{\itemsep}{1pt} \setlength{\parsep}{0pt} \setlength{\parskip}{0pt} 1. first 2. second 3. third Make sure there is no empty line between the #+ATTR_LATEX line and the first list item.


1

Solution: Paragraph spacing: add #+OPTION: \n:t. Fix svg rendering issue: add --shell-escape to config.el (doom-emacs): (setq org-latex-pdf-process '("pdflatex -shell-escape -interaction nonstopmode -output-directory %o %f" "pdflatex -shell-escape -interaction nonstopmode -output-directory %o %f" "pdflatex -...


0

Theoretically, all you have to do is add a header: #+LANGUAGE: es Don't forget to either close and reopen the file, or do C-c C-c on the header so that the setup will be refreshed. That seems to work e.g. for text and HTML export, but LaTeX export does not work for me: it seems to require additional setup that I have not figured out yet. EDIT: just to close ...


1

AUCTeX, used by Aquamacs for tex files, when the option TeX-parse-self is t parses the document preamble, and if it finds some package that requires the creation of dvi (e.g. pstricks) uses latex instead of pdflatex.


4

The problem with your code is that you are applying different replacement functions to the same original text. The result is, the value returned is just the result of the final replacement applied to the original text. You need to accumulate changes. One way to do this is: (defun my-latex-filter-highlightNotes (text backend info) "Highligh custom ...


1

Problem solved! I had to install the texlive-latex-extra package as I was missing some .sty files.


1

I think the example you are working from has mislead you. You can include LaTeX snippets in your org files directly, you don't need to wrap them in a src block. In fact, src blocks are ignored when org tries to preview the LaTeX snippets. Try this: * Org heading This is an ordinary org file. The following LaTeX code can be previewed: \[ e^{i\pi} = -1 \] \[...


0

I encountered the same problem and found the culprit to be rainbow-delimeters, which is listed in the OP's list of minor modes. A workaround is to disable rainbow-delimeters in LaTeX mode. In Doom Emacs, this can be accomplished by adding the following to your config.el: (after! tex (remove-hook 'TeX-update-style-hook #'rainbow-delimiters-mode))


2

When you enter a newline in Python mode, it calls the hook electric-indent-post-self-insert-function. This function calls (eventually) pm-indent-line-dispatcher, provided by polymode to fill the role of indent-according-to-mode. In order for polymode to know what mode you're in, and what the appropriate indentation for that mode is, it needs to know the mode ...


0

If you want all tables to be always left-aligned, then setting org-latex-tables-centeredas @gigiair's answer suggests is the right way to go: you customize it once and never worry about it again. If you want to change the centering behavior only for a single file, then the way to do it is to use the #+BIND mechanism. Add the following line to the top of your ...


0

You can eval (setq org-latex-tables-centered nil) or customize the variable org-latex-tables-centered To customize the latex export, you can browse Org Export LaTeX (customize-group "org-export-latex")


0

In AucTeX, the PDF viewer is specified via the variable TeX-view-program-selection. Find the entry for output-pdf and select a viewer you don't have. You'll get a small warning message in the mini-buffer, but otherwise you won't be interrupted. Alternatively, you could set the value to something you do have that isn't Evince, and you might solve your other ...


Top 50 recent answers are included