Hot answers tagged

7

One possibility would be to use Unicode Character 'ZERO WIDTH SPACE' (U+200B). You need to: bind a key for inserting this character, add it to org-emphasis-regexp-components (don't forget to M-x org-reload for it to take effect). (defun insert-zero-width-space () (interactive) (insert-char #x200b)) (define-key org-mode-map (kbd "C-*") 'insert-zero-...


5

You can embed "raw" html as follows: <p align="center"><img src="images/wim-128.png" /></p> When displayed on GitHub.com, for some reason org-mode's image styling directives are ignored. However GitHub does not ignore styling of <p> tags, so I used the above fix.


5

To center with CSS, you need to use margin-left: auto; and margin-right: auto; try this #+ATTR_HTML: :style margin-left: auto; margin-right: auto; [[/path/to/img.png]]


2

Partly for the purposes of clarification, and partly because it's built-in (to Emacs 24+) and therefore a trivial example, my impression is that you're after something roughly along these lines? (defun my-html-render-current-buffer () "Render HTML in current buffer using `shr-render-buffer'." (require 'shr) (shr-render-buffer (current-buffer))) (add-...


1

You can use the ASCII exporter if you customize the option org-ascii-verbatim-format to %s. Export to a buffer and copy the code there. The following command sets the options temporarily for you as needed and then exports directly into the kill-ring: (defun org+-copy-code () "Export code silently to kill-ring." (interactive) (require 'ox-...


1

It looks to me like it's impossible to mark on a line-by-line basis, allowing you to leverage the already existing message-yank-prefix settings. So I went back and reread the mu4e and message source code to see what else I could piggy-back off. I have a solution below providing you don't need separate formatting for example blocks - for example using org-...


1

Here's what I have in my config for this: (with-eval-after-load 'org ; chars for prematch (setcar org-emphasis-regexp-components " ('\"{“”\[\\") ; chars for postmatch (setcar (nthcdr 1 org-emphasis-regexp-components) "\] - .,!?;:''“”\")}/\\“”") ; forbidden chars (setcar (nthcdr 2 org-emphasis-regexp-components) " \t\r\n,\"")...


1

Try this workaround using #+MACRO: #+MACRO: sbem @@latex:[\emph{$1}]@@ {{{sbem(blah blah)}}} When exported to LaTeX the macro is replaced with: [\emph{blah blah}] This code was tested using: emacs version: GNU Emacs 25.2.1 (x86_64-unknown-cygwin, GTK+ Version 3.22.10) Org mode version: 9.1.2


1

Turns out that this was removed in source blocks in this commit, and presumably the same goes for quote & verse blocks as well.


Only top voted, non community-wiki answers of a minimum length are eligible