4

If you press C-x 4 f, it runs #'find-file-other-window, which is like C-x C-f in that it prompts for and opens a file, but instead of opening the file in the current window, opens it in another one. If you have two windows open (as in your description), it'll use the other one. It will move point into the newly opened file. If you don't want that to happen, ...


3

(define-key term-raw-map (kbd "H-j") 'term-line-mode) (define-key term-mode-map (kbd "H-j") 'term-char-mode)


2

This is not a bug. You can't use emacs commands in term-char-mode, you must toggle to term-line-mode for these commands... But, you can use the terminal commands instead. For example C-w is the terminal backward-kill-word. fortunately, a lot of commands have (almost) the same behavior in terminal and in emacs (C-k, M-c, M-l, M-. ...). Another problem is ...


2

First, check out the wiki on developing for Helm. If you find anything unclear, be sure to create an issue and explain it clearly so others can benefit! I don't use multi-term, but it seems that the problem is that multi-term-buffer-list returns a list of buffers. Helm needs a list of strings to display. What you need is a list of candidates of the form (...


2

To send C-z directly to the shell, open your shell: M-x shell or M-x term, I did not try with mutli-term. Then, once inside the shell, execute: M-x local-set-key RET C-z self-insert-command After that, C-z should send to the background, the task actually running inside the command line, and not the whole Emacs. If you want this configuration to be ...


2

It is correct that ansi-term only supports 8 colors, but, using xterm-color.el instead of ansi-color.el, you get 256 colors. "ANSI & xterm-256 color text property translator for Emacs" https://github.com/atomontage/xterm-color


2

Something like this may help: (add-hook 'term-mode-hook (lambda () (define-key term-raw-map (kbd "C-y") 'term-paste)))


2

I think term-mode-map is only used in line-mode. In char-mode, it uses term-raw-map, so try: (define-key term-raw-map (kbd "s-}") 'multi-term-next) (define-key term-raw-map (kbd "s-{") 'multi-term-prev) This does not seem well documented in the docstrings, so I guess you M-x report-emacs-bug to improve the doc.


1

Emacs 26.1 does not define term-bind-key-alist. If you don't show us what you're doing with that, we can't see what the problem is. That said, it sounds like you're only binding keys in term-raw-map, and not in term-mode-map. n.b. For clarity, I do not believe "lambda only calls 1 of several functions called in body" is something which is happening. I ...


1

The directory where you put multi-term.el needs to be in your load path. Add this to your .emacs before the 'require' call: (add-to-list 'load-path "/home/test/.emacs.d") EDIT This should fix your problem, but as @phil points out, it's bad practice to store lisp code in your .emacs.d directory, and it may cause unexpected problems later on. You should ...


1

I found the problem. As I mentioned in the ticket, I was setting the variable EMACS myself in .zshenv to help setup PATH. As it happens termsupport.zsh also uses this variable name internally. All I had to do is rename my own variable to something else, and it all now works.


1

I had this same problem and asked for help in Github. https://github.com/syl20bnr/spacemacs/issues/10509#issuecomment-376314380 I was able to narrow the problem to my terminal software, I couldn't press C-h which usually is Ctrl-h To see if you have the same problem, press SPC h d k and then press C-h (Ctrl-h) and see what pops up, it should describe C-h, ...


1

What you're looking at is the Emacs notation for describing keybindings. A key binding like C-x means "hold down control and press x", and M-x means "hold down meta and press x". Of course, modern keyboards don't actually have a meta key, so we use alt instead. Additionally, keybindings that use meta can also be activated with escape. Thus M-x can also be ...


1

By default multi-term unbinds '("C-z" "C-x" "C-c" "C-h" "C-y" "<ESC>"). These defaults allow commands like C-x o (other-window) that you can use to move point to another window. If the default setting doesn't include some bindings you'd like to use you can adjust term-bind-key-alist and/or term-unbind-key-alist to the values you prefer.


1

Expanding on @amitp's answer above, here's what I did in my .zshenv file to set my $EDITOR env variable: if [[ -v INSIDE_EMACS ]]; then export EDITOR="emacsclient" else # Regular shell export EDITOR="emacsclient -t" fi


1

Terminals run inside of emacs set an environment variable, INSIDE_EMACS, so you can test that inside of your .bash_profile or .bashrc to set the TERM to something else. (BTW on my system, multi-term seems to be setting TERM to eterm-color automatically…)


1

The help for bs-mode says that a toggles all buffers, and + then marks an entry to display in both views. If that's insufficient I can also see the variable bs-must-always-show-regexp Or you can add or edit a configuration in bs-configurations, which you can select via c or C.


1

Actually I ended up using a slightly different solution. Doing it like it was shown in the answer in this post I get a terminal list with additional information about the terminals. (defclass my-helm-source-terminal-buffers-class (helm-source-buffers) ((candidates :initform (lambda () (mapcar 'buffer-name multi-term-buffer-...


1

I don't know why the background is white where the text is. term-default-bg-color and term-default-fg-color are obsolete, use the term face instead. I'm not sure there's a way to make the background of the terminal anything other than default face, so you'll want the term face to inherit its background color from default. (set-face-attribute 'term nil :...


Only top voted, non community-wiki answers of a minimum length are eligible