8

Add #+LATEX_HEADER: \usepackage{nopageno} to the top of the document.


4

Here is how I got it working. This produces the PDF index, no table of contents in the document, and no section numbering. #+OPTIONS: toc:nil #+LATEX: \setcounter{secnumdepth}{0} Note that I am not using #+OPTIONS: num:nil, because for some reason this option breaks the PDF index. However #+LATEX: \setcounter{secnumdepth}{0} is a workaround to prevent ...


3

You need to use a "closing" heading: *** :B_ignoreheading: :PROPERTIES: :BEAMER_env: ignoreheading :END: Hence, your example should look like this: * More Complex Example some text *** library.py :B_block: #+begin_src python code #+end_src *** ...


3

Emacs looks up the currently logged in user in the password database, and stores it in user-full-name, which org-mode then inserts when exporting. You can edit its value using M-x customize-variable. See (elisp) User Identification as suggested by @Basil


3

You can use an :around advice for org-html-src-block to wrap the code block generated by org-html-src-block with your own html block, e.g.: <div style="background-color:lightgray">. But there is a little subtlety. The argument src-block of org-html-src-block is not really the parse tree of the original buffer. In the process of copying, parsing and ...


3

What about putting the following in the export options: #+LATEX_CLASS: article #+LATEX_CLASS_OPTIONS: [landscape] #+LATEX_HEADER: \usepackage[a4paper]{anysize}


3

Hey this answer solved my similar problem. A bit late but I had the same issue today. As mentioned, I add the following code snipped to my .spacemacs/.emacs config: (require 'org) (require 'ox-latex) (add-to-list 'org-latex-packages-alist '("" "minted")) (setq org-latex-listings 'minted) (setq org-latex-pdf-process '("pdflatex -shell-escape -...


3

When using org-export C-c C-e, there's a menu that shows the export options (html, plain text, etc.). In that menu, there's an option C-b for body only. Toggle this, then export, and it will export just what's in <body>.


3

Here's one way to do it using org-id (there are, of course, other ways of finding a subtree in the buffer). emacsclient -e "(progn (find-file \"$1\") \ (org-id-goto \"$2\") \ (org-html-export-to-html nil t))" First you have to create an ID for the entry you want to export using org-id-get-create and then: $ ...


3

Built-in approach The noweb approach is built in to Org-mode but I believe it is a bit clumsy for your purpose. Therewith you can substitute marked names in source blocks with their result values within a source block. Thereby, the names are themselves names of source blocks that are evaluated to get the results. Applied to your example that could look like ...


3

The reason that org-babel evaluates code blocks in :noexport: sections is that it does not know what depends on what and makes the worst-case assumption that any code block results you choose to export depend on every code block in the file. It's not an unreasonable assumption: presumably you chose to put all these code blocks in the same file exactly ...


3

I've met the same problem. The only way I've found is to redefine the function that handles that part of the export and to put it as a emacs-lisp source block at the beginning of my org file. Here is what I did: (defun org-latex--caption/label-string (element info) "Return caption and label LaTeX string for ELEMENT. INFO is a plist holding contextual ...


3

I use code like this to do that. (defun scimax-ob-clear-all-contents () "Clear all src-block contents in the buffer." (interactive) (save-excursion (goto-char (point-min)) (while (org-babel-next-src-block) (org-edit-special) (delete-region (point-min) (point-max)) (org-edit-src-exit)))) If you just want to remove all the ...


2

You misinterpreted the meaning of the first argument of org-publish-org-to. It is the export backend and not a function. Because of the special structure of the pandoc backend replacing org-pandoc-export-to-html with 'pandoc does not work. If you do that you only get the filtered org stuff in your output files. The final translation to html is missing. (That ...


2

If you want a two-way sync with google calender, perhaps you should try org-caldav (https://github.com/dengste/org-caldav)? I have been using it for some time with mixed, mostly positive, results.


2

While the previous answers are helpful, I'll add a bit more of an explicit recipe for Org mode. By default, Org mode adds a rather unhelpful hypersetup section. You can prevent this addition by adding the following line to your .emacs file: (customize-set-value 'org-latex-with-hyperref nil) In addition, if you want to pass any options to hyperref or url ...


2

You can use the function org-export-to-file This will let you specify the file you want to save to and the back-end for the export. (org-export-to-file 'html "README.html" )


2

Adding ":wrap SRC text" worked. #+BEGIN_SRC emacs-lisp :results output :exports both :wrap SRC text


2

There doesn't seem to be any way to specify the column classes in the output that org-mode produces. I did find though that I am able to use nth-child to achieve what I need. You can add something like this to your .org file: @@html: <style> table colgroup col:nth-child(1) { width: 10%; } table colgroup col:nth-child(2) { width: 40%; } table ...


2

I'm new to answering on StackExchange, so if I'm doing something wrong I'm sorry, and any advice is welcome! This is probably a bug, but this is a temporary solution I have found :). I ran this on Emacs 26.1, org-mode 9.2 on Ubuntu 18.04. Unfortunately I didn't manage to find the bug, but maybe this will be easier to use in the meantime. This is what I did ...


2

The org-export-backends variable contains the backends that should always be available. In Emacs 24/Orgmode 8, it will be (ascii html icalendar latex), which is why the ODT options aren't shown. You have to customize the variable, e.g. M-x customize-option RET org-export-backends RET: Org Export Backends: [X] ascii Export buffer to ASCII format [ ]...


2

I don't think you can get rid of section numbers with num:nil and still get the index. As I explained in the chat, num:nil produces starred sections which latex treats as unnumbered sections. But then it also fails to add them to the .aux file as \contentslines, so the PDF does not get any information that can be used to generate the index.


2

It turns out that the problem is with the way the latex compiler is called. Its own working directory is the original directory of the .org file, not the new directory of the .tex file. So that means that while it finds the .tex file in the correct directory (/export), its own working directory is still ./, so that's where it puts the output files. I had to ...


2

One way that might not be too bad, if the tables are all structured the same way, e.g. the first column is always a first level heading (and there are no newlines in it), and the second column should always be second columns, and all notes for a book are in one row, is to extract the tables using a Python script. I would put this script at the top of an org-...


2

To use a specific journal template in Org Mode you need to create a LaTeX class. This is what I use in my init file for Springer journals: (add-to-list 'org-latex-classes '("Springer" "\\documentclass[natbib]{svjour3} ("\\section{%s}" . "\\section*{%s}") ("\\subsection{%s}" . "\\subsection*{%s}") ("...


2

To export a buffer without expanding noweb references, you can set the following at your src header, as per documentation: #+begin_src language :noweb no-export To define that globally, you can add the following at the top of your Org File: #+property: header-args :noweb no-export Or language specific: #+property: header-args:languagename :noweb no-...


2

The @@backend: @@ construct doesn't work with newlines. I think you can do something like this to get a selective export only for a particular backend, in this case html. I am not sure if you can also get other non-html formatting in this. #+BEGIN_EXPORT html conditional multi line paragraph #+END_EXPORT


2

This is actually a LaTeX problem. But maybe it only occurs in the context of Orgmode. LaTeX does not like to break a line after a heading. So the whole text appears on one page and most of it is cut off. You can avoid the problem by inserting some invisible paragraph in each section. The following LATEX_HEADER setting in your Org file would do that: #+...


2

The correct syntax is #+ATTR_LATEX: :placement [!htb]{0.75\textwidth} [[./image.png]] Note that the attributes are specified by a single colon followed by the name of the attribute (e.g. :placement or :width) and the value of the argument is copied verbatim into the appropriate place in the exported latex file (hence [!htb], not {!htb}, since LaTeX ...


2

The ob-sql-mode package is not updated for org-mode 9.2 yet. There you find as of 2019-04-20 the following lines in master: (eval-after-load "org" '(progn (add-to-list 'org-src-lang-modes '("sql-mode" . sql)) (add-to-list 'org-structure-template-alist `(,org-babel-sql-mode-template-selector "#+BEGIN_SRC sql-...


Only top voted, non community-wiki answers of a minimum length are eligible