5

Another approach is to delete all non-level-2 entries before parsing the export buffer. This is different to what @gregoryg is proposing in that it also skips the body/text directly following non-level-2 headings. No need to use tags. (defun export-translation (backend) (org-map-entries (lambda () (unless (= (org-current-level) 2) (let ((...


4

There are a couple of options for this, to me the easiest way is grouping templates using the built-in mechanism. My way to use capture templates is based in memory muscle rather than digging a long menu, so how the menu is displayed should be concise in case I don't recall what key was for something. I do call capture using F12, then if I want to insert a ...


2

You can use ox-extra functions from the org-plus-contrib package. This would require you to tag all top-level headlines with the "ignore" tag. (require 'ox-org) ; if exporting to Org Mode (require 'ox-extra) (ox-extras-activate '(ignore-headlines)) After tagging your top-level headlines, export to a plain text or Org file, e.g. C-c C-e O o You can ...


2

Unless you spend your days exporting org documents I'd stick to the export interface because it's mature and takes care of the little details. If you still want something to bind to a single key, a very minimal implementation of it could be: (defun my/to-latex-file() (interactive) (org-export-to-file 'latex (read-from-minibuffer "Filename for latex ...


2

What you're asking for looks like Org Capture Templates. (define-key global-map "\C-cc" 'org-capture) (setq org-capture-templates '(("c" "Calls arranged in a date tree" entry (file+datetree "~/calls.org" "Calls and Meetings") "* %^{type|Call|WalkUp|Meeting}: %^{problem} %T + %? + RESULT + " :clock-in t :clock-resume t))) To ...


2

Octave is peculiar (or maybe ob-octave is peculiar). In particular, the name ans seems to have special meaning. Try this: #+name: test-data #+begin_src octave :session test_case :exports both a =[ 1 2; 3 4; 5 6]; ans = a #+end_src #+RESULTS: test-data | 1 | 2 | | 3 | 4 | | 5 | 6 |


1

You can ask for the results to be the output (the default is value) and then use the disp option you already tried; place this :results output on the begin_src line.


1

I get the same result as you do and I'm not sure how it is supposed to work (I suspect bugs but I have not investigated). However, it does work better in a session: #+name: test-octave-function #+begin_src octave :session foo function retval = mysum(x, y) retval = x + y; end ans = mysum(5, 12) #+end_src #+RESULTS: test-octave-function : 17


1

You need to use LATEX_HEADER_EXTRA instead of LATEX_HEADER. You also need Org mode release 9.1 or later. Be sure to clean out the ltximg/ subdirectory in order to regenerate clean preview images after you apply the necessary fixes. The documentation says The LaTeX export back-end appends values from ‘LATEX_HEADER’ and ‘LATEX_HEADER_EXTRA’ keywords to ...


1

Adding :exports none should take care of that: #+BEGIN_SRC bash :exports none pandoc --bibliography=biblidatabase.bib --filter pandoc-citeproc \ latexfile.tex -o outputfile.odt #+END_SRC See Exporting Code Blocks in the manual.


1

You need a function that collects the title of the original file (the file visited by the current buffer when org-capture was called). If you have org-collect-keywords (added in b4e91b7e949), you can use: (defun get-title (file) (let (title) (when file (with-current-buffer (get-file-buffer file) (pcase (org-collect-keywords '("...


1

As an alternative, you can use the ox-pandoc package. Pandoc itself has a command line option called --self-contained which will embed images in html. To you use this for just the pandoc HTML5 exporter, by putting this in your .emacs: (setq org-pandoc-options-for-html5 '((standalone . t) (self-contained . t))) Also, you could have it for html4 instead/as ...


Only top voted, non community-wiki answers of a minimum length are eligible