Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

Filter by
Sorted by
Tagged with
0 votes
2 answers
32 views

Binding functions associated with package names to H-x

The following function constructed by @dalanicolai has been adapted in a way that allows a user to automatically select a function affix name galaxy, protoc or typex, which is then bound to H-x. What ...
user avatar
  • 359
0 votes
0 answers
21 views

How to let AuCTeX automatically detect tcolorbox-environments

When I create a new environment via the \newenvironment-Command, Auctex automatically detects it and when I type C-c C-e the new environment is suggested and when I chose it, it asks for the right ...
user avatar
2 votes
1 answer
96 views

Is it possible to wrap a small package not listed on MELPA/ELPA via use-package? How to do it?

I like this Emacs package called Emacs Centered Point link. I must highlight that it is not listed on MELPA/ELPA. Until now, I have just appended the snippet to my init file with the following and it ...
user avatar
0 votes
0 answers
13 views

How to change this slime configuration on the init file from the classic imperative installation to a declarative approach via use-package?

When I first installed Slime, I used to install things via the classic M-x and package-install. Then, I inserted the following configuration: (slime-setup '(slime-fancy slime-asdf slime-indentation ...
user avatar
0 votes
1 answer
29 views

How to change this wrap-region configuration on the init file from the classic imperative installation to a declarative approach via use-package?

When I first installed wrap-region, I used to install things via the classic M-x and package-install. Then, I inserted the following configuration: ;; Emacs minor mode to wrap region with tag or ...
user avatar
0 votes
0 answers
18 views

How to change this Paredit configuration on the init file from the classic imperative installation to a declarative approach via use-package?

When I first installed Paredit, I used to install things via the classic M-x and package-install. Then, I inserted the following configuration: (autoload 'enable-paredit-mode "paredit" "...
user avatar
0 votes
1 answer
31 views

Can't install code as package

I've recently started to look into the Blazor framework and noticed there is no available major-mode for editing .razor files, which are essentially a mix of C# and HTML. I then started creating a ...
user avatar
1 vote
2 answers
164 views

After updating my packages, two packages are not working anymore. How to solve this? Downgrading it? Bug reporting to maintainers? Fixing?

This is my config file. As you can see, on line 351, there is: ;; Update my Emacs' packages every week (use-package auto-package-update :custom (auto-package-update-interval 7) (auto-...
user avatar
0 votes
0 answers
20 views

Bug-hunter finds error but it shouldn't (false positive)

I suspect I'm doing something very stupid but I can't figure out what. I have some problems with Eshell, and I was advised to use Bug-hunter. I installed it through Elpa. When I launch it (M-x bug-...
user avatar
1 vote
0 answers
36 views

Symbol's function definition is void: package-install-selected-packages

In order to install and remove packages automatically (which is especially useful when using Emacs for the first time on a new computer), I have the following lines in my ~/.emacs: ;; Specify required ...
user avatar
0 votes
0 answers
17 views

list-packages says certificate has expired. What I need to do?

I have not used Emacs for about six months. Today I tried to use M-x list-packages and there is an error, although I remember that there was no such error before: I use Emacs 27.1 on 32-bit Windows 7,...
user avatar
0 votes
0 answers
19 views

Emacs' CopyWithoutSelectAction EditWithoutSelection

The Intellij's emacsIDEAs plugin say, Porting some great extensions of emacs to Intellij IDEA. such as AceJump, CopyWithoutSelectAction. And new created EditWithoutSelection (Cut/Move/Replace without ...
user avatar
  • 387
0 votes
1 answer
46 views

While running "package-refresh-content" show me this. Why? Emacs 28.1

Debugger entered--Lisp error: (error "Location https//elpa.gnu.org/packages/ is not a url nor an absolute file name") signal(error ("Location https//elpa.gnu.org/packages/ is not a ...
user avatar
1 vote
1 answer
100 views

Reducing straight.el Bloat

TL;DR: Is there a way to have straight.el not check out a package via git repo, and have it download slim melpa packages like package.el does? Also, is there a way to have it refrain from ...
user avatar
  • 155
0 votes
2 answers
108 views

Org-superstar-mode not enabled from config file

I'm just getting started with emacs, and I'm trying to enable org-superstar-mode automatically upon launching an org file. I've installed org-superstar, and I can run M-x org-superstar-mode when in an ...
user avatar
0 votes
1 answer
64 views

How to remove leftover packages from unused layers

An easy example is adding themes-megapack to dotspacemacs-configuration-layers in .spacemacs, then running SPC f e R, and then observing all the added *-theme packages in your package-selected-...
user avatar
0 votes
0 answers
30 views

recursive require of slime error when trying to require symex

I'm getting the following error when doing (require 'symex) or (use-package symex). Error (use-package): symex/:catch: Recursive ‘require’ for feature ‘slime’ This is emacs 27.1 on Ubuntu 21.10 and ...
user avatar
0 votes
1 answer
308 views

symbol's function definition is void

My dotemacsfile looks like the following. (require 'package) (add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/") t) (package-initialize) ;load and activate ...
user avatar
0 votes
0 answers
100 views

package-selected-packages variable not being automatically updated?

I noticed that after I edited my package-selected-packages by hand it no longer gets automatically updated when I install a package with package-install command. How do I get it back to updating ...
user avatar
0 votes
0 answers
91 views

problem connecting to melpa packages

I'm new to emacs, and I'm having problems when trying to set up my init.el file to connect to the melpa packages site. I'm using MacOS Big Sur version 11.6, and Emacs version 26.2 (9.0) since there ...
user avatar
0 votes
0 answers
80 views

package-load-descriptor: End of file during parsing

I've encountered this error on an Arch Linux system running Emacs-27.2. I sync my Emacs ~/.config/emacs/init.el which calls a host of other files located under ~/.config/emacs/settings/*-settings.el ...
user avatar
  • 263
1 vote
1 answer
36 views

How start Emacs only with specific packages?

Linux Mint 20, Emacs 27.1 In my init.el file I loaded many packages. But sometime I need to load only some specific packages. E.g. emacs -Q and only vertico+marginalia+theme The question is: How I ...
user avatar
  • 3,445
0 votes
2 answers
186 views

"Failed to download ‘melpa’ archive" when I run package-refresh-contents

Have started seeing this error after I installed a new version of Emacs. My package code in init file is (require 'package) (setq package-archives '(("gnu" . "http://elpa.gnu.org/...
user avatar
  • 491
2 votes
0 answers
194 views

Emacs and ASP.Net Razor Pages

I am trying to get .razor and .cshtml pages working in Emacs. My config is Doom Emacs with (csharp +lsp +dotnet). No issues with the C# code, that all works fine other than absurd refactoring ...
user avatar
  • 121
0 votes
0 answers
26 views

Does gnutls-log-level fix the Elpa issue in Emacs 26?

I was trying to fix the well known error for Emacs 26 on downloading packages from GNU Elpa. Playing around, it seems that setting the gnutls-log-level to >0 fixes the problem, without skipping the ...
user avatar
1 vote
1 answer
100 views

How to programmatically install packages from init.el (using emacs27)?

I have this in my init.el file (when (not (package-installed-p 'geiser)) (package-install 'geiser)) But when I start emacs, I get the error Warning (initialization): An error occurred while loading ...
user avatar
  • 113
1 vote
1 answer
214 views

Setup ox-extra in an elisp script to be run without init file

I'm new to Emacs and I am trying to write an elisp script to automate the org-mode export for GitLab CI. The idea is that on the worker I simply run emacs --batch --no-init-file --load build.el --...
user avatar
  • 241
1 vote
1 answer
53 views

How can I handle unfound ELPA packages?

Sometimes I encounter packages claiming to be on ELPA, yet neither package-install nor [1] or [2] list them. How do I know if the problem is on my or the contributor's side? Simply manually installing ...
user avatar
  • 629
0 votes
1 answer
245 views

How can I install and enable this theme?

I have been using this solarized theme for many years now: https://github.com/sellout/emacs-color-theme-solarized. This theme used to be available in the MELPA repos, but it is no longer available ...
user avatar
0 votes
1 answer
58 views

Package needs to be reinstalled every time spacemacs is started

I install a theme using M-x package-install [return] doom-themes. And it installs the themes and I use the themes. However, when I close spacemacs and start it again, this package is gone and needs to ...
user avatar
1 vote
1 answer
30 views

How to create a structure instance out of a -pkg.el file?

Package foo description is stored inside a file foo-VERSION/foo-pkg.el with a cl-defstruct definition that complies to package.el package-desc structure type with a package-desc-from-define ...
user avatar
  • 621
2 votes
1 answer
31 views

For convenience, how should I load a package whenever a specific other package loads?

I have a package that enhances the functionality of another package. To save the user the effort of any additional configurating, I would like my package to load automatically if the larger package ...
user avatar
  • 201
0 votes
1 answer
63 views

Why not store all .el/.elc Elpa files inside the same directory to speed up Emacs startup?

Would it not be possible to modify Emacs package system to store all Emacs Lisp files installed from Elpa-compliant packages inside the same directory? That would dramatically reduce the number of ...
user avatar
  • 621
1 vote
1 answer
180 views

Required help with making LSP (Scala Metals) working

My current emacs version is 27.2, OS is Ubuntu 20.04,Java version is 11.0.11. I was following the official guide of installing metals on emacs, did a little change from the course at the start (I ...
user avatar
  • 51
1 vote
0 answers
128 views

How to set package-user-dir with Emacs 27 with package-quickstart and distinguish between graphical and terminal mode?

Goal: I would like to do the following with Emacs 27+: take advantage of the package-quickstart option to speed up startup, have 2 independent elpa directories: ~/.emacs.d/elpa when emacs runs in ...
user avatar
  • 621
3 votes
0 answers
42 views

How to declare a version of a local copy of existing package

Is it possible to identify the package version of a local copy/clone/fork of a Elpa supported existing package? Problem Scenario: A Elpa supported package (lets called it package-foo) hosted on some ...
user avatar
  • 621
2 votes
2 answers
230 views

Helm installing issues

I am trying following a book (Mastering Emacs) and right now stuck on a section about working with Helm. I tried to install through various means, listed there, and found online, my last attempt was ...
user avatar
  • 51
0 votes
1 answer
320 views

What is the difference/purpose between "require" and "package-install"?

I am trying to understand the subtle nuances of Emacs' packaging system(s). I do not find that anyone has really clarified or explained the difference between two, what I assume to be, key components ...
user avatar
  • 105
1 vote
1 answer
541 views

Emacs error cannot load file counsel

I'm getting this error whenever I try to open Emacs: Debugger entered--Lisp error: (file-missing "Cannot open load file" "No such file or directory" "counsel") require(...
user avatar
2 votes
1 answer
121 views

How to use package-generate-autoloads

I am teaching myself autoloads for "home-made" packages. Official Docs suggest to use update-file-autoloads or update-directory-autoloads on the related package file or directory, which ...
user avatar
  • 1,638
1 vote
0 answers
55 views

Cannot load some modes via elpa

Some of my major modes, installed via ELPA, error during load as, for instance for markdown-mode, Debugger entered--Lisp error: (file-missing "Cannot open load file" "No such file or ...
user avatar
  • 415
2 votes
1 answer
120 views

Elpher loads for Gopher but not Gemini using Doom Emacs

I am using the most up to date version of Doom Emacs, and I am trying to use Elpher to access Gemini pages. While it loads up Gopher pages just fine, any time I try to pull up a Gemini page I get a &...
user avatar
2 votes
3 answers
324 views

Connect to Melpa on Port 80 in Setup Script

I'm trying to setup emacs in a docker image that I am creating. I would like to create the image with a particular melpa package installed. This is my Dockerfile: FROM ubuntu RUN apt-get update RUN ...
user avatar
1 vote
0 answers
24 views

show which package repo was used to obtain a package

I'm trying to submit a bug report to emacs-evil, and they ask me from which repo evil was installed. I'm just using the version that came bundled with doom-emacs. How can I know which source was used ...
user avatar
2 votes
1 answer
171 views

Woes with installing and loading s.el

I'm running Emacs 27.1(9.0) on OSX 11.2.2 and have failed at installing and configuring the package s.el from https://github.com/magnars/s.el/ Here's a list of things that I tried: Copied s.el into ~/...
user avatar
  • 169
0 votes
0 answers
19 views

How can I reset the source code of an Emacs package to its original state?

Suppose I have installed company-0.9.13, which other packages depend on (mostly third-party company completion backends). I unwisely edited company-mode's source code directly in the ~/.emacs.d/elpa/...
user avatar
  • 553
0 votes
0 answers
44 views

How to find the file-system location of a package?

Packages on my system are installed to ~/.config/emacs/elpa,although I assume it's possible to configure where packages are located. How can I programmatically find the file-path for a package name (...
user avatar
  • 7,277
0 votes
0 answers
105 views

Getting uninstall packages offer after package updates

Each time I call up list-package and update, I get this message after the updates Operation finished. Packages that are no longer needed: 43. Type ‘M-x package-autoremove’ to remove them Below is ...
user avatar
  • 2,737
0 votes
0 answers
28 views

How to force package-utils-upgrade-all to completely replace packages when upgrading?

lsp-mode doesn't support upgrading the package, instead, a full re-install is required each time (see report). (In my case, deleting the directory and re-installing works, upgrading doesn't). Is there ...
user avatar
  • 7,277
1 vote
1 answer
306 views

nov-mode returns binary buffer and "File mode specification error: (error Invalid version syntax: ‘’ (must start with a number))"

When opening an epub file with Nov-mode I get a binary buffer in fundamental mode and an error message File mode specification error: (error Invalid version syntax: ‘’ (must start with a number)). ...
user avatar
  • 608

1
2 3 4 5
9