29

set package-check-signature to nil, e.g. M-: (setq package-check-signature nil) RET download the package gnu-elpa-keyring-update and run the function with the same name, e.g. M-x package-install RET gnu-elpa-keyring-update RET. reset package-check-signature to the default value allow-unsigned This worked for me.


12

If you try to install the package gnu-elpa-keyring-update (which seems to have the purpose of updating the keys used by the package manager), you will see in its description that you can do: gpg --homedir ~/.emacs.d/elpa/gnupg --receive-keys 066DAFCB81E42C40 on the commandline to get new keys manually. To make sure you are asking for the correct key (...


8

There are several: Quelpa Quelpa allows for fetching packages from arbitrary sources and building them into a format that can be installed by package.el Straight Install Emacs packages listed on MELPA, GNU ELPA, or Emacsmirror, or provide your own recipes. Packages are cloned as Git (or other) repositories. Borg Assimilate Emacs packages as Git submodules. ...


7

Add the following before package-initialize: (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3") This is apparently a bug in Emacs 26.2 for MacOS. I found this solution in this reddit thread.


6

Elpa seems to be having issues again. (Reddit discussion.) Maybe try adding (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3") to your config as mentioned here.


4

It might be this bug: https://debbugs.gnu.org/34341. It's fixed in Emacs 26.3+ and the workaround is: (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3") Source


3

A solution in several lines of code in elisp Emacs init file: ;; Some combination of GNU TLS and Emacs fail to retrieve archive ;; contents over https. ;; https://www.reddit.com/r/emacs/comments/cdei4p/failed_to_download_gnu_archive_bad_request/etw48ux ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34341 (if (and (version< emacs-version "26.3") (>= ...


2

The answers here are a bit dated. This issue seems to have been fixed as of emacs 26.3.


2

get the puglic key with: gpg2 --homedir ~/.emacs.d/elpa/gnupg --receive-keys 066DAFCB81E42C40 Attention: your version could be a different key !


2

Alternatively, you could upgrade to a newer emacs, e.g. on Ubuntu: sudo add-apt-repository ppa:ubuntu-elisp/ppa sudo apt-get update sudo apt-get install emacs-snapshot This way you avoid doing all this: https://elpa.gnu.org/packages/gnu-elpa-keyring-update.html


2

The main part of indenting is the parsing. There is the Simple Minded Indentation Engine for this kind of stuff. The manual also gives an example for the indentation rules. octave-mode in octave.el is an example for a mode that uses SMIE


2

First of all run emacs with --debug-init from your terminal and check if it complains about being unable to verify the elpa archive due to an invalid key. If that is the case, copy the public key displayed to you. I ran into this problem because the GPG keys used by the ELPA package manager to verify authenticity of packages downloaded from the GNU ELPA ...


1

clj-refactor is included with Spacemacs. package-install only lists packages that aren't already installed. Try package-list-packages to see all packages, installed and uninstalled.


1

One can use use-package. In a file (which could be your init file, but doesn't have to be): (require 'package) (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t) (package-initialize) (setq package-archives (seq-remove (lambda (element) (equal "gnu" (car element))) package-...


1

I solved this by setting the variable gnutls-algorithm-priority to TLS-1.2. (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.2"). It's because on Windows or Windows Subsystem Linux (WSL) the local gnutls-utils may not support TLS1.3.


1

I encountered this issue. I solved it using the following steps in order: Installing Gpg4win Make sure that the folder c:/Progra~2/GnuPG/bin is on your path before any other installed versions of the GnuPG executables (in my case, I had it installed via msys2). Note that Progra~2 expands to "Program Files (x86)" on my system (I am using the 64 bit version ...


1

You may have to just use http instead of https Here is what I have (essentially removed the s from https) Not the perfect solution but something to get me going. (setq package-enable-at-startup nil) (add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/")) (add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/...


Only top voted, non community-wiki answers of a minimum length are eligible