Hot answers tagged

16

If you use magit, you can press e at the unmerged file in magit status buffer (started by pressing M-xmagit-statusRET) to start ediff session for resolving the conflicts


10

M-x vc-resolve-conflicts RET I bind it to C-xv<


10

You can use the minor mode smerge-mode to move between conflicts and resolve them. You can open ediff to resolve conflicts with C-c ^ E while in smerge mode.


9

According to https://lists.gnu.org/archive/html/emacs-orgmode/2015-11/msg00425.html ob-sh was renamed ob-shell in org 8.2 ... and I cite from there: org-babel-get-header was removed in 0d000f5 (babel: small change in API., 2015-10-29), but the old ob-sh.el is still trying to call it. That means you should replace (sh . t) by (shell . t) in your call of ...


6

auto-fill-mode is what you're looking for. You can enable it automatically for editing text by adding this to your config: (add-hook 'text-mode-hook 'auto-fill-mode) You can customize how long lines in your text documents should be by customizing the fill-column variable. For example: (setq-default fill-column 80) If you want to to make sure that lines ...


5

The highlighting is performed by diff-hl-mode from the diff-hl package, and can be toggled with M-x diff-hl-mode, or unconditionally disabled by passing a negative argument (M-- M-x diff-hl-mode interactively, (diff-hl-mode -1) from lisp) like most minor modes. To find out yourself which minor mode is causing the effect you could use f1 m (describe-mode) ...


5

@lawlist is correct: This question is a (not-so-obvious) duplicate of How to change word wrap highlighting in Emacs on StackOverflow. Since we can't close questions against posts on other StackExchange sites, I'm going to repeat the answer that I gave over there: Highlighting of content that exceeds word wrap bounds is provided by whitespace-mode (which is ...


5

It seems that it's not a problem of your install but an issue on the Melpa side. I've tracked the issue down as far as that the file "archive-contents" that Emacs tries to download from Melpa is currently corrupt / truncated: http://melpa.org/packages/archive-contents Guess we'll have to wait until the Melpa guys do something about it.


4

I got around this by first starting emacs with emacs --insecure and once that worked and downloaded and what it needed, I was able to start emacs --daemon fine.


4

I found the answer here. Instead of set-default-font, I needed the following: (setq default-frame-alist '((font . "Source Code Pro-12")))


4

MELPA is apparently having issues at the moment.


3

TL;DR Emacs Prelude binds C-xC-b to ibuffer. What T does in the *Buffer List* buffer, /v does in the *Ibuffer* buffer. This filter was only added in Emacs 26, however, so before that you have to emulate it: /fRET will filter by buffers associated with a file, but this does not exclude all special buffers, such as Magit buffers. You can then, for example, ...


3

I don't see an option in prelude to disable smartparens globally -- looks like it is enabled in a prog-mode-hook and a few other places. You could advise smartparens-mode (and perhaps smartparens-strict-modeas well) to prevent them from enabling the mode. Assuming you are on Emacs 24.4, try this: (advice-add #'smartparens-mode :before-until (lambda (&...


3

In a shell window, make a backup of your files (now), including the autosave files. After backup. You can probably copy the autosave file over the empty file. However, and this is very important, make a backup, before you start trying to fix it. Then when all is good (or not), you need to create a backup strategy, for all of your important data.


2

The following should do what you want: (key-chord-define-global "xx" nil) You can add it to your personal configuration file. This has been described in Prelude's README.


2

There is no need to dispatch you configuration in Spacemacs, config.el, keybindings.el and funcs.el are facultative. But for now you have to put ELPA packages in packages.el and extensions (i.e. source code not in an ELPA repo) in extensions.el. I'm no expert with Prelude but here is my guess: I think you can match Prelude module and Spacemacs layer. ...


2

Cached Tramp data will be removed by M-x tramp-cleanup-all-connections.


2

Elethan's tip lead me to the answer here, which essentially involves disabling system wide OSX Command-Control-D shortcut by calling: defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 '<dict><key>enabled</key><false/></dict>'


2

Have you tried helm-projectile-switch-to-buffer?


2

eshell saves your aliases to the file specified in the eshell-aliases-filevariable, This variable should by default be inside the value of eshell-directory-name which prelude seems to override. You should be able to override it back to something you can put under VC like this: (eval-after-load 'prelude-editor (lambda () (setq eshell-directory-name "/...


2

You can use that: (global-set-key (kbd "C-a") 'move-beginning-of-line) Since this is defined on prelude-mode, you can alternatively redefine this directly for this minor mode map: (define-key prelude-mode-map (kbd "C-a") 'move-beginning-of-line) If you don't want write any additional setup on your init file, as ultimate alternative you can just disable ...


2

Emacs will load your init.el file first. Nothing else gets loaded unless init.el says so. You can answer your question by working through init.el and looking for require or load lines, which will be processed in the order they appear. This is recursive, so if init.el requires sourceA.el, and sourceA.el requires sourceB.el, then sourceB.el gets loaded too.


2

Can some one walk me through the explicit key chords to: Select/open all of the filtered files in the minibuffer. Ivy does not provide a built-in way to act on all completion candidates at once. The closest you can come in general is by enabling "calling" via C-oc (requires the ivy-hydra package; see (ivy) Hydra in the minibuffer). When "calling"...


1

No. Set it yourself, e.g. (global-set-key (kbd "C-c C-b") 'bury-buffer).


1

thanks tobias (smartparens-global-mode -1) does the trick Update: This doesn't work. ( I checked the next day) Still looking for an answer. I can manually do M-x smarparens-mode after opening each file, which is cumbersome


1

This one is slightly convoluted, but you're looking for: M-x customize-option RET sp-override-key-bindings RET Add entries for, e.g., String: <C-right> with Symbol: nil to unbind that smartparens key sequence.


1

I know nothing about Prelude, so maybe this won't be helpful, but subword-mode is buffer-local, so if it seems to be active everywhere Prelude is probably using global-subword-mode instead. So try (global-subword-mode -1) in your ~/.emacs. You can also try and turn it off selectively in some modes with lines like (add-hook 'c-mode-hook (lambda () (...


1

You run that macro with M-x foobar.


1

On Windows 10, I solved the problem by starting Emacs with the admin prompt (seems that admin rights matter). Also, you should check on whether gnutls is properly installed, following the instructions here: https://stackoverflow.com/questions/36950871/failed-to-download-melpa-archive


1

Essentially, you've said that you have a whole lot of stuff in a sack, and something changed somewhere, and the resulting behavior changed. And you're asking for help removing that behavior change. That's all pretty nebulous. (What is "guy version of emacs"?) Please provide a succinct, step-by-step, minimal (or close to it) recipe to reproduce the problem....


Only top voted, non community-wiki answers of a minimum length are eligible