Hot answers tagged

9

While doing due research on this, I stumbled upon a small section in the ESS manual: The default value of ess-eval-visibly (t) means that ESS calls block Emacs until they finish. This may be undesirable, especially if commands take long to finish. Users who want input to be displayed and Emacs not to be blocked can set ess-eval-visibly to 'nowait. This ...


3

As mentioned in my comment, you need to pass the variable as a :var header on the #+begin_src line, not on the #+name: line. But you also need to specify that the results be output to a graphics file. The following worked for me: #+TBLNAME:kuchen | 100 | ABC | | 3 | DEF | | 123 | XYZ | #+name: piechart #+begin_src R :results file graphics :file pie.png :...


3

Here's a quick and dirty approach. Depending on what you want there's lots of room for improvement. (defun head-at-point () (interactive) (let ((target (thing-at-point 'symbol))) (ess-send-string (ess-get-process ess-local-process-name) (concat "head(" target ")\n"))))


2

The reason I was having this problem is that I didn't have (require 'poly-R) in my init file. I only had (require 'poly-markdown). After adding (require 'poly-R), I can now press Enter within a chunk and it will stay in ess-r-mode.


2

Note that script-proc-buffer will always be new-buffer since that is an existing buffer when make-comint-in-buffer is called. To bind kill-process to the key sequence q make it somehow interactive and use local-set-key with the wanted buffer current, e.g.: (with-current-buffer script-proc-buffer (local-set-key "q" (lambda () (interactive) (kill-process)))...


2

It's no longer required to use Rterm.exe; you can just use R.exe directly. To configure the program name that emacs/ESS uses, set the variable in your .emacs like this: (setq inferior-ess-r-program "R") Alternatively, press C-h v, select the inferior-ess-r-program variable, and use the Customize interface to set and save the setting. If you don't have the ...


1

The command M-x R is provided by the package ESS, which is available via the Melpa repository. You need to install this package before you can start the R process this way. There was a period in early 2019 when the R command was broken in ESS, but it has since been fixed, so installing the current release of ESS should restore the R command.


1

This is from ESS's news file, which will be in the next release of ESS (likely 19.07). If you've installed ESS from MELPA it's already a part of it: * 'smart-underscore' and 'ess-smart-S-assign-key' have been removed. Users who liked the previous behavior (i.e. underscore inserting "<-") should bind 'ess-insert-assign' to the underscore in ...


1

Thanks @Drew for your answer, but it did not work (maybe I did not made it correctly :-)). I tried to add this in my .emacs file: (setq special-display-buffer-names '("*Help" "*help[R]*" "*Help*")) but nothing changed. Then, I tried various settings for the variable ess-help-frame-alist, and I did not manage neither... However, I finally found a ...


1

I am using the package shackle for that. After the package is installed the following setting should do what you want (setq shackle-rules '(("*R:?[0-9]?*" :regexp t :same t))) (shackle-mode 1) If you do not want to use an external package you might be able to adapt this answer https://emacs.stackexchange.com/a/13585/15268 to your needs. Note: the regexp ...


Only top voted, non community-wiki answers of a minimum length are eligible