Skip to main content
Share Your Experience: Take the 2024 Developer Survey
6 votes

Detecting variable changed outside customize

Emacs version 26.1 and higher allows you to trigger the debugger when a variable changes. Place the following code near the beginning of your init.el: (debug-on-variable-change 'semantic-lex-c-...
Programator2's user avatar
5 votes

How to get semantic syntax highlighting on emacs for C/C++ code

color-identifiers-mode does this for variables, if I understand your question correctly. rainbo-identifiers-mode too, I think. Screenshot is from the former one.
Alejandro Erickson's user avatar
2 votes

Multi-line echo area for displaying function signature with semantic-idle-summary-mode

Short answer: The full semantic tags are shown in the minibuffer if semantic-idle-truncate-long-summaries is customized to nil and eldoc-echo-area-use-multiline-p is customized to non-nil. The not so ...
Tobias's user avatar
  • 33.2k
2 votes

Can Semantic and Company coexist?

I did run into trouble. Emacs would become unresponsive trying to complete code and at other times when I do not know what was executing. I disabled Semantic again and Emacs went back to normal again. ...
Mikael Springer's user avatar
1 vote

How can I get C/C++ context-sensitive completion with Company?

I suggest using irony-mode with company-irony for completion instead of semantic as semantic is generally too slow and simplistic - ie. it often doesn't offer completions when you would think it ...
alexmurray's user avatar
1 vote

How can I get C/C++ context-sensitive completion with Company?

You probably want to follow the tutorial here and setup company-clang to get better candidates.
expez's user avatar
  • 381
1 vote

Completion for variables in C using company-gtags, or not Semantic

I have followed the directions at this blog which supplements the C ide stuff by Tudho to install rtags and irony (as suggested by Dmitry) and it provides the features I asked for. I'll expand with a ...
Alejandro Erickson's user avatar
1 vote

Long pause after typing `std::` when using semantic with auto-complete

I've hit this same problem before and I "solved" it by changing the value of ac-delay from 0.1s to 1.0, like so: (set-variable 'ac-delay 1.0) That means that as I'm typing it only attempts the auto-...
GWO's user avatar
  • 11

Only top scored, non community-wiki answers of a minimum length are eligible