New answers tagged

0

It seems that the bug occurs because I set straight-use-package-by-default using the customize-interface. When I set the variable outside of custom-set-variables everything works fine.


0

You need to add the straight keyword in the use-package macro call e.g. add :straight t From straight.el documentation https://github.com/raxod502/straight.el#integration-with-use-package To use use-package, first install it with straight.el: (straight-use-package 'use-package) Now use-package will use straight.el to automatically install missing ...


-1

In general you need to initialize the package system if you're going to use packages at init time. i.e. Do this first: (setq package-enable-at-startup nil) (package-initialize) (That said, I'd be slightly surprised if use-package didn't do that itself, so maybe this isn't the issue; but it's certainly worth testing it.)


2

Opening Two Buffers on Startup You could add a function to emacs-startup-hook which switches to the first buffer you want, splits the window, moves to the next window, and switches the second buffer (this is exactly what the function below does). You didn't specify whether the buffers you wanted to display were file buffers or already existing buffers. Here ...


3

You can put (setq inhibit-startup-screen t) into your init file. Then you start-up in the scratch buffer. You can use the variable initial-buffer-choice to set up your own preference.


Top 50 recent answers are included