New answers tagged

0

A workaround for this is to disable file watchers: (setq lsp-enable-file-watchers nil) ... and then restart the workspace: (lsp-restart-workspace) I'm not sure if this effectively disables a useful feature, but I can't get it to work otherwise. The solution was described here: https://github.com/golang/go/issues/38032 More about file watchers here: https://...


1

You can lengthen the timeout using the lsp-response-timeout option: https://emacs-lsp.github.io/lsp-mode/page/settings/mode/#lsp-response-timeout Of course, what you really want to do is make gopls faster. Probably not much you can configure in Emacs to do that.


1

As mentioned in the comments, a workaround for this issue is to start emacs on a folder (or on nothing) instead of on a single source file. This was discussed for VScode with gopls as backend here: https://stackoverflow.com/a/49977881/497180


Top 50 recent answers are included