New answers tagged

1

tl;dr @drew is right, you have a conflict. Use C-backspace in Emacs to delete the word to the left of the point. At your shell command like use C-w to do the same. Long answer @Drew is correct, you have a conflict between iTerm and Emacs. Unfortunately there's not much you can do about that, so let's focus on what you want to do, "delete word". As you've ...


1

I'm not familiar with iTerm. But it sounds like it is capturing the keys you specified, which you want, in general. You just don't want it to do that when Emacs has the input focus. You'll probably need to check the iTerm doc to see if there is some way to exclude certain applications (e.g. Emacs) from iTerm's key capturing.


0

One further update for macOS/iTerm2 users: iTerm now ships with a "Report modifiers using CSI u" option within preferences that configures LeoNerd's libtermkey for you with a single checkbox. As of this writing (iterm2 3.3.9) it can be found in Preferences -> Profiles -> Keys. There is no longer any need to remap keychords one by one in iTerm, although I ...


Top 50 recent answers are included