0

I'm currently having difficulty with a graphical glitch in Emacs 24.4.1. Occasionally all the text in my current frame will tear, and I'll have to force Windows to redraw everything by covering up the Emacs frame with another window. This doesn't seem to happen with any consistency, and only occurs with Emacs. I'm not entirely sure how to reliably reproduce the error, rather it just happens randomly whenever I'm working in it. Any help would be greatly appreciated, and an example picture is attached below.

Emacs Graphical Glitch

  • What OS? Do you have any special settings for :height | :width | :weight in any face that is being used in those buffers? How about any special line height? How about any special line spacing? Since you get the top of every line, those are the likely suspects. Your default font would be the first place you should check for a strange configuration, since it's affecting everything. I would try using a plain 'default font with nothing special, and with no themes and see if your problem magically disappears. And, of course, try Emacs -Q -- i.e., with nothing at all. – lawlist Apr 1 '15 at 17:30
  • If you can give a recipe to reproduce the problem that starts from emacs -Q (no init file), regardless of your platform, then please report it using M-x report-emacs-bug. Unfortunately, you say that it happens "occasionally" (and presumably unpredicatably). I too notice lack of refreshes occasionally with Emacs 24.4 (far more than with earlier releases), but I haven't found a good recipe to reproduce the problem. I have a feeling that they've tried to improve performance by skipping some redisplays that used to happen, and they've gone overboard. But finding the problem might not be easy. – Drew Apr 2 '15 at 3:30
  • Thanks for commenting, and apologies for the delay. I'm running Windows 7 and I'm not using any special settings for the face in those buffers. The only thing I'm using is the custom theme monokai, and the problem persisted even with Emacs -q when I tried it. I honestly can't tell you how to reproduce the problem because I literally had a span of 4 days where nothing happened, and then it started happening again. If no one else has had this problem happen, then I'm guessing it's just something going very wrong on my end, so I'll just live with it unless it gets really bad. – Allan Zhang Apr 6 '15 at 23:54
2

I added

(global-set-key (kbd "<f5>") 'redraw-display)

to my .emacs file so that I could quickly recover from a very similar issue. (In my case, entire regions of the emacs window display correctly for several seconds after emacs receives the focus, then major sections go blank and the (icon bar?) across the top gets muddled.

This happens whether I have focus-follows-mouse (through a registry mod, arranged so the window is not raised when it has focus) or click-to-focus (which also raises the window above the obscuring window.)

From C-h C-a: GNU Emacs 24.5.1 (i686-pc-mingw32) of 2015-04-11 on LEG570) On various Dell laptops running Windows 7

  • I am able to reproduce the tearing effect when starting emacs with "runemacs.exe -Q" This is still Win 7 Pro, Dell E6410, emacs 24.5.1 of 2015-04-11 – Donald Locker Apr 20 '16 at 11:23
  • No special action - cover most of the emacs window (from just below the [File Options Buffers Tools ...] menu bar to the status line, then raise emacs above the obscuring window. – Donald Locker Apr 20 '16 at 12:41
  • I wasn't expecting a comment on this after almost a year! In my case, I actually talked with some IT people and found that the main issue is actually that my laptop, a Thinkpad T420, shipped with a refresh issue on the display, which was causing my problems. I doubt that you're facing a similar cause to your problem, but just be aware that may also be a hardware component to it. – Allan Zhang Apr 23 '16 at 4:22
  • Indeed - I haven't seen this issue in several weeks now. Usually gets worse (or occasionally better) after a Windows "update"; after a machine rebuild (14-20 Apr; hard disk crash), it was glitching very regularly. After a batch of updates on 22 Apr, all has been well-behaved. – Donald Locker May 10 '16 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.