4

Here's my proxy setup:

(setq url-proxy-services '(("no_proxy" . "my-corp-proxy")
                           ("http" . "my-corp-proxy:8080")
                           ("https" . "my-port-proxy:8080")))

I can use eww to access HTTP sites, but when I try to access HTTPS sites I get this response:

enter image description here

I've installed gnutls as well; evaluating (gnutls-available-p) gives t.

How do I solve this issue?

  • Can you access HTTPS sites with curl? $ http_proxy=my-port-proxy:8080 curl https://www.example.com – Wilfred Hughes Dec 31 '15 at 19:36
  • Yes, I can access HTTPS sites with curl behind the same proxy. – David Dai Jan 1 '16 at 4:18
  • Can you access HTTPS sites without the proxy? – feklee Jul 16 '16 at 14:19
  • @feklee no. Im inside corporate network, no direct internet connection. – David Dai Jul 18 '16 at 3:58
  • If you remove configuration of url-proxy-services, do you get the same error message? Can you access the web from IE? I’m asking because maybe you have to set up the proxy using Windows settings. – feklee Jul 18 '16 at 7:07
1

I had the same problem and I have finally got it working.

I applied the patch in https://debbugs.gnu.org/cgi/bugreport.cgi?bug=11788#52.

Then, to solve

error in process filter: url-http-generic-filter: Wrong type argument: number-or-marker-p, http/1.1

I just had to add a line to url-http.el:462 which was

(skip-chars-forward "HTTP/")        ; Skip HTTP Version
(skip-chars-forward "http/")        ; Skip HTTP Version
  • 1
    FWIW, the fix is included in Emacs 26. – Basil Feb 8 '18 at 15:21
  • Also, the first argument to skip-chars-forward is interpreted as an unquoted regexp character set, not literally. – Basil Feb 8 '18 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.