1

I recently upgraded to (K)ubuntu 16.04 which includes Emacs 24.5.1. Since the upgrade, Emacs stalls for more than three minutes when opening any Python file. The problem occurs when opening a new Python file as well as on existing files. I tried eg.

emacs --no-init-file example.py

where the file can be a literal hello world program, non existing or any small Python script. The problem also occurs when opening a Python file after editing other files or when using dired to open the file. I left no extensions installed on that system.

CPU load and memory footprint are normal while Emacs stalls (below 1% on my system). Ctrl+G allows circumventing the problem. Once the first Python file has loaded, all other Python files load normally w/out delay.

I tried removing all configuration files

rm -r .emacs*

but that did not help either (note that I could not reproduce the problem on other (K)Ubuntu systems). The only message I get from Emacs is likely not related: "Warning: no abbrev-file found, customize `abbrev-file-name' in order to make mode-specific abbrevs work.". How can I get Emacs to be usable for editing Python files again? Any hints are welcome. Thanks.

  • Do you see the same problem even when you do emacs -Q example.py? Note that the -Q option is different than -q. – Kaushal Modi May 16 '16 at 17:42
  • Possibly sounds like a symptom of this: emacs.stackexchange.com/q/18438/50 – Malabarba May 16 '16 at 20:05
  • According to your answer it's too late, but for this kind of problem setting debug-on-quit can get a backtrace from hitting Ctrl+G which is usually helpful for solving. – npostavs May 16 '16 at 20:53
1

To resolve this issue, I first ruled out the configuration and local elpa packages. After making sure that the same issue does not reproduce on other installations w/ the same emacs version, the remaining cause could only be buried in the system configuration. After re-installing all emacs related packages and removing all emacs related python extensions from the system (there were yasnippets, emacs-goodies-el, pylint etc.), the problem was resolved. Unfortunately, I don't know which of the packages caused the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.