3

When I'm using emacs-shell, I often try to run files for which a backup (with ~ ending) exists.
I use Helm, and if I try to auto-complete the name of a file called, say, seed-rand.rb, with an existing backup, I get a result like the image below:

annoying-completion-at-point

completion-at-point really isn't helping me here—is there any way of telling it to ignore files ending with ~? (That's what it does when helm-mode is turned off.)

And if that's not possible, is there any way of just turning this helm feature off without toggling helm-mode every time I want to do so?

  • I'm unable to reproduce the behavior you describe above. I get the same completion options with helm-mode disabled. Also, note that the function used to compute the completion candidates is tags-completion-at-point-function in both cases, so we shouldn't expect any difference either. – Qudit Jan 14 '17 at 19:36
  • A bit confused by this—any suggestions on what to try? – tcelferact Jan 14 '17 at 22:35
  • Also, if I use C-h c to ask Emacs which function is running when I hit <tab>, it returns completion-at-point? Is that the wrong way to figure out the function that runs? – tcelferact Jan 14 '17 at 22:37
  • @abc helm-mode should only affect how the completion candidates are displayed --- not what they are. This is the behavior I observe when trying to reproduce your problem. – Qudit Jan 15 '17 at 2:15
  • 1
    When the global minor mode helm-mode is off (it is by default), the behavior of completion-at-point will not be changed by helm at all. If you want to turn on helm-mode and don't want it to change completion-at-point, customize user option helm-completing-read-handlers-alist. – xuchunyang Jan 15 '17 at 4:56
0

@xuchunyang solved this (see the comments section):

"When the global minor mode helm-mode is off (it is by default), the behavior of completion-at-point will not be changed by helm at all. If you want to turn on helm-mode and don't want it to change completion-at-point, customize user option helm-completing-read-handlers-alist."

I had success when performing this solution via M-x customize.

  • Why the downvote? I only answered myself so that the question registered as answered on the site, and I credited the person that provided the solution. I'm happy for @xuchunyang to answer instead, and if they do I'll accept their answer instead of mine. – tcelferact Jan 17 '17 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.