1

I'm running Debian Jessie. I have installed emacs24-lucid package. I tried running emacs --daemon and got this:

Loading 00debian-vars...
Loading 00debian-vars...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done
Loading debian-ispell...done
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done
Loading /etc/emacs/site-start.d/50festival.el (source)...
Loading /etc/emacs/site-start.d/50festival.el (source)...done

Backtrace:
emacs[0x8130d29]
emacs[0x81189e6]
emacs[0x812fb9e]
emacs[0x812fc0b]
linux-gate.so.1(__kernel_sigreturn+0x0)[0xb775ed1c]
emacs[0x8194292]
emacs[0x819abac]
emacs[0x819b36d]
emacs[0x80ed071]
emacs[0x80ec057]
emacs[0x81857d0]
emacs[0x81b893d]
emacs[0x8185317]
emacs[0x8186873]
emacs[0x8184b09]
emacs[0x81a718b]
emacs[0x81a7867]
emacs[0x81857a7]
emacs[0x81b893d]
emacs[0x8185317]
emacs[0x818565b]
emacs[0x8185a03]
emacs[0x81a7fa5]
emacs[0x81857a7]
emacs[0x81b893d]
emacs[0x8185391]
emacs[0x818565b]
emacs[0x81b893d]
emacs[0x8185391]
emacs[0x818565b]
emacs[0x8184e11]
emacs[0x818793b]
emacs[0x81b9963]
emacs[0x8185391]
emacs[0x818565b]
emacs[0x81b893d]
emacs[0x8185391]
emacs[0x8186873]
emacs[0x8184b09]
emacs[0x8186f67]
emacs[0x8118ef4]
...
Error: server did not start correctly

Not sure what could be causing this. Any ideas?

EDIT: I can start server from within emacs. As a workaround, I am using an emacs instance as the "server".

2

It's a bug. Upgrade to Emacs-25 to see if we fixed it already, and if not please M-x report-emacs-bug.

0

I use 32-bit emacs24-lucid on jessie with --daemon, its working fine.

Try running emacs -Q --daemon to see if there is a package in jessie installed, which causes the problems. If this is working you might to deinstall a debian package or disable the emacs-start-code. If running with -Q is not working then this answer will not help you.

Emacs-extensions installed as debian packages store their startup code in /etc/emacs/site-lisp/ or /etc/emacs24/site-lisp/. Also have a look at /usr/local/share/emacs/site-lisp/. You can temporary rename/remove those files to find the package which causes this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.