0

I installed GNU Emacs 25.2.1 64bit and downloaded spacemacs the way it is described in their git repo.

Now when starting up through runemacs.exe the following output occurs:

Warning (spacemacs): 
Error connection time out for melpa repository!
Warning (spacemacs): 
Error connection time out for gnu repository!
Warning (initialization): An error occurred while loading ‘c:/Users/p.hoefer/AppData/Roaming/.emacs.d/init.el’:

File error: Cannot open load file, No such file or directory, bind-map

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the ‘--debug-init’ option to view a complete error backtrace.

Googling for this problem showed me it is a common issue but the solution there did not worked for me - or I am too stupid to use them right.

  • 1
    Which Emacs build are you using? I had the same problems when I was using a build without GnuTLS, but when I switched to a build from emacsbinw64.sourceforge.net they disappeared. – Arnot Sep 1 '17 at 9:37
  • emacs-25.2-x86_64.zip - thats the one I loaded – xetra11 Sep 1 '17 at 12:01
  • Can you try running it with the --insecure-flag on the commandline? That might help. – Arnot Sep 1 '17 at 12:07
  • It was the binary problem - the one from sourceforge worked! – xetra11 Sep 1 '17 at 12:08
  • 1
    I don't know about you, but I think a setup where starting Emacs connects to remote hosts is a very bad idea, e.g. for performance reasons, for reasons of use when disconnected, for reasons of security, and on and on and on. I suggest you report this as a bug. – Stefan Sep 1 '17 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.