2

I used to compile emacs from the master branch every month or so and looks like there has been a lot of changes to term.el (move to lexical binding) and when I open term or ansi-term there is always a % character at the end of every command i execute in term.

Have anybody else run into this issue? If so any fixes ? I'm reverting back to using emacs 26 RC until then.

  • 1
    This isn't the Emacs bug tracker. Please report a bug with M-x report-emacs-bug. – wasamasa Mar 3 '18 at 7:43
  • @wasamasa -- 99.9 percent of the people (who read emacs.stackexchange.com and/or reddit/emacs) do not have your level of expertise. When you make a comment, only a few people partially or fully understand anything you say. It would behoove you to provide some background information to help everyone understand why Emacs 27.0.50 inquires are better suited to the limited forum of report-emacs-bug. I am among the .05 percent who partially understands some of your comments, but since it was your comment / recommendation, I'll leave any clarification up to you if you deem it appropriate. – lawlist Mar 3 '18 at 9:44
  • @lawlist This sounds like a bug on master, not intentional behavior you can change by setting an option. Hence why I suggest them to ask on the Emacs bug tracker instead of here. That's all there is to my comment. – wasamasa Mar 3 '18 at 14:58
3

This should now be fixed in the master branch. As mentioned in the comments, bugs should be reported to the bug tracker. If you are not sure if something is a bug, testing with emacs -Q is a good indicator (and you should do that anyway, before reporting).

4c33ad4a24: Fix line-wrapping for term.el (Bug#30775)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.