1

I have a buffer on markdown-mode with the following contents.

        10         20        30        40        50        60        70

- a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a
  a a a a a a a a a a a a a a a a a a a a a a a a


- A aaaaaa aa aa aaaaaaa. Aaa aaaa aaaaaa a
  aaaaaaaaaa. Aaaaaa-a. (progn (set-fill-column 70) (fill-paragraph))

If I place the cursor after the last parenthesis and running eval-last-sexp, nothing changes. I expected something like the following

        10         20        30        40        50        60        70

- a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a a
  a a a a a a a a a a a a a a a a a a a a a a a a


- A aaaaaa aa aa aaaaaaa. Aaa aaaa aaaaaa a aaaaaaaaaa. Aaaaaa-a.
  (progn (set-fill-column 70) (fill-paragraph))

Why does this happen? Same happens if I am on text-mode.

0

The paragraph is already filled.

If you add another SPC char after the period (.) then you see the paragraph filled differently. Or if you set variable (option) sentence-end-double-space to nil then you'll also see it filled differently.

  • Thank you @Drew. I still don't understand why it is already filled, though. – Tássio Jan 8 at 23:23
  • 1
    It already has newline chars at the line ends, and all of the lines are, in effect, filled to the auto-fill max length. So no need to change the line lengths. – Drew Jan 9 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.