0

I think that this is a newbie question, but here it goes:

I have installed Flycheck just as in the official page. Therefore, in my .emacs file I added the following lines (after installing):

(package-install 'flycheck)
(global-flycheck-mode)
(package-install 'exec-path-from-shell)
(exec-path-from-shell-initialize)

However, when I open a .py file, I get this error message:

Warning [flymake seila.py]: Disabling backend python-flymake because (error Cannot find a suitable checker)

Warning [flymake seila.py]: Disabling backend flymake-proc-legacy-flymake because (error Can’t find a suitable init function)

How would I fix these errors? Seems to me that some file/configuration is missing. I've found this (partial) solution that makes the second error disappear, but It does not seem to be an effective solution.

Thanks in advance.

0

Your warning messages (notice that they say "warning" rather than "error") come from flymake which is a package similar to flycheck except it comes bundled with Emacs. So those messages are not directly related to your flycheck config.

| improve this answer | |
  • Thanks for noticing my typos! I don't even know flymake. Do you think is it safe to disable it? – José Joaquim Jun 11 at 21:16
  • @JoséJoaquim: It's not enabled by default, so it must be enabled by something in your config. Rather than disable it, you can probably make it work by installing pyflakes (and use it instead of flycheck). – Stefan Jun 11 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.