1

I am running emacs version GNU Emacs 27.1 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.20, cairo version 1.16.0) of 2020-09-19, on Ubuntu 20.04 on a laptop with 4K display in 200% scaling mode (hiDPI).

Emacs does not adapt fully to scaling changes. On a large monitor I use 100% and everything renders ok. But when using the laptop screen only, the horizontal divider of the mode-line is incorrectly scaled. Can the size of the divider be customized?

I also have to change the Default font size every time I change between 100% and 200% scaling, is there a setting in Emacs where that can be automatically set based on screen resolution/scaling settings?

EDIT

The mode line is not an issue any more, since I was informed that it was a scrollbar that concealed the text.

I still have a problem when changing from large monitor to laptop screen in 4K resolution. I have to manually change the default font size, and the cursor is too small.

Does Emacs have support for automatic adaptation to HiDPI screen sizes?

Icorrectly scaled horizontal divider

3
  • The question isn't very clear. Please provide a step-by-step recipe, starting from emacs -Q (no init file), showing what you've tried, and saying what you expected to see and what you saw instead.
    – Drew
    Feb 14, 2021 at 23:56
  • 2
    If you don't need it you could disable the horizontal scroll bar: (horizontal-scroll-bar-mode -1). Feb 15, 2021 at 9:17
  • You might file a bug report about the horizontal scroll bars (M-x report-emacs-bug). Regarding the issue with hidpi support, you should ask about it in a new question. Feb 16, 2021 at 10:32

1 Answer 1

0

A solution to the main problem is to hide the horizontal scroll-bar, either as suggested by Arch Stanton in a comment, or by disabling it in:

Options -> Show/Hide -> Scroll bar -> Horizontal

I did not understand that it was the scrollbar that was incorrectly rendered so that the text in the mode line was covered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.