3

Is there any way of disabling AUCTeX from auto-promping for optional overlay options in a Beamer document? I use global overlay options, and the prompting for local ones can be annoying when writing long documents.

3
  • Just for \item? In that case set LaTeX-beamer-item-overlay-flag to nil.
    – giordano
    Jan 20, 2015 at 3:41
  • Thanks. Please make this an answer and I will approve it.
    – NVaughan
    Jan 20, 2015 at 16:17
  • Where did you find that option? I couldn't find it in the official documentation?
    – NVaughan
    Jan 20, 2015 at 16:40

1 Answer 1

3

In order not to be prompted anymore for overlay specification in \item like macros, set the variable LaTeX-beamer-item-overlay-flag to nil. You can do it locally or globally, for the latter case customize that variable or add this code to your init file:

(setq LaTeX-beamer-item-overlay-flag nil)

As most style-specific options, this variable is not documented in the official manual of AUCTeX, but you can find them browsing customize-group RET LaTeX-style RET.

1
  • 1
    I've changed something in auctex (can't remember what) to add the frame and minted environments with C-c C-e, and unfortunately, this annoying thing started popping up as well. Great that there is a solution.
    – Ajned
    Feb 16, 2020 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.