On using an image link as,


in org-mode, emacs doesn't toggle the inline image display. org-toggle-inline-images works well on start-up. I run a presentation using M-x epresent-run epresent and come back to edit mode from the presentation mode by pressing q. Then the image display stops toggling.

What I get after quitting epresent-mode:


What I want:

enter image description here

This behavior is seen after I get into presentation mode using epresent and come back to edit mode by pressing q.

  • 1
    This isn't the default behavior. Look into your init file for mentions of either org-toggle-inline-images (newer Org) or org-toggle-iimage-in-org (older Org). Also see this link: orgmode.org/worg/org-configs/org-config-examples.html - this is probably how you get it in the first place.
    – wvxvw
    Mar 7 '15 at 7:53
  • this command works before i run epresent-run but after going into presentation mode & coming mode, toggling stops
    – Madhavan
    Mar 7 '15 at 15:33
  • 3
    I think that toggling depends on some text property which Org puts in this kind of links. Probably presentation mode wipes all such properties. I'd write to epresent maintainers about the problem. They'd be the ones to know how to work around it.
    – wvxvw
    Mar 7 '15 at 16:20
  • Yes, it looks like a bug to be filed on epresent-mode.
    – Malabarba
    Mar 7 '15 at 20:19
  • 1
    i already raised one github issue - : github.com/eschulte/epresent/issues/23
    – Madhavan
    Mar 8 '15 at 3:00

To toggle images, do either:

C-c C-x C-v


M-x org-toggle-inline-images

To do this in #+OPTIONS, it looks like you can set it in the #+STARTUP: https://orgmode.org/manual/In_002dbuffer-Settings.html - see inlineimages and noinlineimages

  • This is not a real answer to the question of the connection between epresent and org-mode.
    – Tobias
    Nov 23 '21 at 8:49
  • @Tobias I did the best I could do here - if you have a superior response, please provide it and I will certainly upvote you if I can tell it is good.
    – Aaron Hall
    Nov 23 '21 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.