23

My orgmode was recently updated to the recent 8.3, and I found that I can't export my init.org file as HTML any more.

I'm getting the following output in *Messages* buffer:

org-babel-exp process emacs-lisp at line 34...
org-babel-exp process emacs-lisp at line 44...
org-babel-exp process emacs-lisp at line 51...
... hundreds of lines like these ...
apply: Wrong type argument: listp, #("John's Emacs Config" 0 19 (:parent (#0)))

It seems that's it's having trouble parsing some of the headers. I tried removing the TITLE and AUTHOR headers and it was able to export.

  • 2
    This is likely an issue with the new Org being compiled while an older version is loaded. Try installing in a clean session without Org loaded. – Kyle Meyer Aug 15 '15 at 6:44
25

The full sequence of steps that worked for me:

  • From the command line:
    • Run emacs without loading the init file: emacs -q
  • In emacs:
    • run C-u M-x org-reload
    • Use package-list-packages to uninstall org: select it then d x
    • Use package-list-packages to reinstall org: select it then i x

After restarting emacs, everything worked.

  • 7
    C-u M-x org-reload was enough for me. – Alfred M. Dec 5 '16 at 16:54
0

I've run into this problem with: GNU Emacs 25.1.50.1 (x86_64-apple-darwin15.5.0, NS appkit-1404.47 Version 10.11.5 (Build 15F34)) of 2016-07-26 and Org-mode version 8.3.5 (8.3.5-elpa).

I was able to get around it by removing any of my "titles" or any line it complained about.

For instance removing this block, i was able to export to both ox-reveal and ox-twbs:

#+TITLE:  My Emacs Configuration
#+AUTHOR: JJ Asghar
#+EMAIL:  jjasghar@email.com
  • I should say, also following up with the above answer resolved my issue too. – JJ Asghar Jul 26 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.