1

Since the last upgrade of org-plus-contrib to 20170210 I can no longer create clock tables in org mode. Computing the begin statement creates an empty table (see below) and throws the error org-clocktable-write-default: Wrong type argument: char-or-string-p, nil.

#+BEGIN: clocktable :maxlevel 5 :scope tree2 :tcolumns 1
#+CAPTION:  [2017-02-12 So 14:42]
|
#+END:

I have not changed anything in the clocked tree nor in the init file. So, to me it seems that the error results from changes in the org-clocktable command. Have you also run into this error? Has anybody found a solution to that?

UPDATE from 27.02.2017: The clocktable command works if I duplicate a single org file and run it as a different user with a not customised init file. Does anybody has a tip how to interpret the error message, so I can find the causing error in the init file?

  • I have this problem too, cant find the source of the problem. I've got my .emacs in a git repo so I checked out an old version where Im certain clocktable worked, but the problem remained. Your workaround worked for me too so its probably an upgraded or a downloaded package that cause this bug. – vcmsxs Apr 4 '17 at 9:48
  • @vcmsxs: I've solved the problem yesterday by commenting out parts of my init file. I am using org-ref and it turned out that a custom variable pointing to a folder that didn't exist anymore caused the error: (setq org-ref-pdf-directory "~/Documents/Bibliography/notes/org-ref-pdfs/") The clockmode error was fixed once I corrected this variable. – Alexander Gogl Apr 4 '17 at 11:21
1

I've found the error by commenting out lines in the emacs' init file, starting with a large selection of code and narrowing it down to one line. It turned out that a custom org-ref variable causes this error when it points to a folder that doesn't exist:

(setq org-ref-pdf-directory "~/Documents/Bibliography/notes/org-ref-pdfs/")

  • Found it. I had a ox-freemind.el in my load-path. – vcmsxs Apr 4 '17 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.