0

I've been trying to build Emacs 28 from source on my MacBook Pro running macOS 10.15.5. I managed to get the feature/native-comp branch working, but I found it to be too unstable, so I deleted Emacs and tried rebuilding off of the master branch.

Now when I build off of the master branch, I can't get the GUI'd Emacs to build. I've tried blowing away the source directory and rebuilding from scratch, but that didn't fix anything.

Here's how I build:

$ ./autogen.sh
$ ./configure --without-ns && make
$ make install

I worry I might have bungled deleting the old app. Any suggestions on what I might try next?

3

When using the flag --without-ns, that means do not build Emacs specifically for the MacOS platform. How about using --with-ns instead, or no flag at all? The build script should automatically build Emacs for MacOS when building on that platform -- i.e., when not using --with-ns or --without-ns. The package Emacs.app will be in the nextstep folder of the Emacs source code.

Here is an excerpt from the ./configure --help output:

Optional Packages:

  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)

  --with-ns               use Nextstep (macOS Cocoa or GNUstep) windowing
                          system. On by default on macOS.
2
  • Sheesh… when did I make that typo? Thank you @lawlist! I'm getting a different error now, but I think I'm good on this issue. – Ashton Wiersdorf Jul 27 '20 at 19:34
  • For future readers: I also had to say CC=/usr/bin/clang ./configure --with-ns to get this to work on macOS Catalina. After that I was able to run make without any problems. – Ashton Wiersdorf Aug 7 '20 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.