0

I want to use the package ox-ipynb in spacemacs.

I tried adding under dotspacemacs-additional-packages, but I guess since it's not on melpa, spacemacs couldn't find it.

I've also tried downloading the ox-ipynb.el file itself and loading it directly in my org-mode buffer like this:

#+BEGIN_SRC emacs-lisp
  (load-file "~/emacs/ox-ipynb.el")
#+END_SRC

which gave me: load-with-code-conversion: Symbol’s value as variable is void: Skip

Any suggestions?
And in general, how do I make spacemacs install packages that are not on melpa?

0

You can do this by using a quelpa recipe under dotspacemacs-additional-packages in your dotfile as follows:

    (ox-ipynb :location (recipe
                         :fetcher github
                         :repo "jkitchin/ox-ipynb")))

Currently, this possibility is only described in the docs about 'configuration layer development`

Alternatively, you can install my small update of benneti's spacemacs jupyter layer. I once started that update, but probably I did not consider it finished as I did not push it to github (I guess I just wanted to add some things to the README). But as far as I know it is fully functional (not tested), so I pushed it now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.