0

I'm writing a presentation using Org-mode and beamer. The problem is that all the frames are putted into a single one. I have the following code:

#+TITLE: \textbf{example}
#+AUTHOR: \large{sdjfioa}
#+DATE:
#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation,smaller]
#+LaTeX_HEADER: \usetheme{Ilmenau}
#+LaTeX_HEADER: \usecolortheme{beaver}
#+OPTIONS: H:2 toc:nil title:nil
* This is the first structural section

** This should be a frame
but it is not

** This should be another frame
fajsiodjfoiasjdfoii

the exported .tex file contains the following:

\begin{document}

\maketitle
\section{This is the first structural section}
\label{sec:org7d325e6}

\subsection{This should be a frame}
\label{sec:org5055c4a}
but it is not


\subsection{This should be another frame}
\label{sec:orgcbe0add}
fajsiodjfoiasjdfoii
\end{document}

And the pdf is like this

0

The commands to export a beamer document to a {buffer, file, PDF file, PDF file and Open} are different from the normal LaTeX export commands:

  • C-c C-e l B exports to a LaTeX beamer buffer.
  • C-c C-e l b exports to a LaTeX beamer file.
  • C-c C-e l P exports to a PDF file.
  • C-c C-e l O exports to a PDF file and opens the file.

N.B. That's a CAPITAL P for exporting to PDF and a CAPITAL O for exporting to PDF and opening the file. Make sure that you use the correct command.

  • Yes I use those commands to export, specifically the last two. – Gerico0889 Mar 9 at 13:51
  • Are you sure, you are using CAPITAL P and CAPITAL O? Your tex file does not show any evidence of that. Mine e.g. says \begin{frame}[label={sec:orge8610a5}]{This should be a frame} but it is not \end{frame} – NickD Mar 9 at 13:57
  • Now that i look closer, you used a capital p and o, I don't have those options when opening the export menù with C-c C-e. Running org-beamer-export-to-pdf works though. – Gerico0889 Mar 9 at 13:59
  • You should not have to do this, but try (load-library 'ox-beamer) and see if the options appear in the menu. – NickD Mar 9 at 14:01
  • Yes, using that command worked. Now the other options show up. Thank you! – Gerico0889 Mar 9 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.