3

I updated to Emacs 28 recently and org-capture now puts a small character in the left fringe for captured items. I know that I can set fringe-mode to no-fringe to not see any fringe, but that's not what I want. I want to specifically turn off or set to nil the fringe character for org-capture.

System: Emacs 28.1, Org 9.5.2

To reproduce:

emacs -Q
M-: (setq org-capture-templates '(("t" "Todo" entry (file ~/test.org) "* TODO item")))
M-x org-capture t
C-c C-c
C-x C-f ~/test.org

screenshot showing fringe character to the left of captured text

I read in the manual about fringe indicators, so I tried setting all bitmap values in fringe-indicator-alist to nil, but that didn't work. There are some other answers about fringe indicators, but they indicated that fringe-indicator-alist was the place that fringes are set. None of them were helpful for my problem related to org-capture.

Where is this fringe character set? How do I remove it without turning off fringe-mode entirely?

1 Answer 1

4

Org Capture sets a bookmark for the last stored item. The bookmark library is responsible for setting this fringe mark, not org. Check out the option bookmark-set-fringe-mark, which was introduced in 28.1.

1
  • Thanks! This is my first time hearing about bookmarks. It looks like another option to solve this problem would be org-capture-bookmark.
    – jrasband
    Jun 14, 2022 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.